Jump to content
Corsair Community

Vengeance RGB Pro SL loosing signal with iCue after Windows goes idle

Recommended Posts

TL;DR: as the title states, my Vengeance RGB RAM starts to lose signal with iCue after my PC goes idle and turns off the monitors (think Screen Saver mode). A few minutes after signal gets rocky iCue will completely lose signal with the RAM, giving the little red triangle warning, and rebooting my PC is the only way to get the ram signal back.
The RAM never stops functioning, like doing its job as system Memory. So no BSOD or PC crashes or anything, just loss of communication with iCue so lighting and temp monitoring stops.

I've been trying to Google search and forum search, but the only results I'm getting are really out-dated and usually are issues with their PC coming back out of Sleep, like PC mostly powered down Sleep or Hibernation, which I don't use.

Okay, I know this'll get pretty long, but I've been troubleshooting this and chasing things for a long time now and I want to give you guys as much detail as I can up front.

Windows 11 Pro (v. 21H2)
Asus ROG Strix B550-A (BIOS v. 2803)
AMD Ryzen 5 5600X
Asus ROG Strix RTX 3080
Corsair Vengeance RGB Pro SL 3600Mhz 32gb- 4x 8gb (v 0.06.36) CMH32GX4M4D3600C18W
iCue (v. 4.32.129)
Asus Armoury Crate (v.

First off, Armoury Crate is the ONLY RGB software I'm running besides iCue. I am ONLY running it to control the lighting on my Graphics Card via iCue, it is set up per the instructions by Corsair. I never have it actively running, just whatever automated launch stuff it does in the background. I have disabled everything possible in AC that has anything to do with lighting.
I already have Armoury Crate Service set to Delayed Start in Services.msc, but this didn't change anything.

Long story on what's happening and what I've tried: 
I have my Windows Power Settings set to turn off my Monitors after 10 Minutes of inactivity, everything else stays powered on and running (full power on, if you will) I'm NOT talking about Hibernation or Sleep. Whenever I come back to my PC and "wake" it up I can see that the RGB on my RAM starts to pause every now and then and when I open iCue and look at the RAM in the Dashboard view, #1 will have random temperature spikes down to 0 deg. After a few minutes (never the same amount of time) iCue will completely lose signal with all 4 RAM sticks. SOMETIMES I can get the signal back by Locking my windows session (Windows Key + L) and then logging back in, but the signal will still be inconsistent (temps dropping to 0 deg) and will eventually drop completely again. Completely rebooting is the only "fix".

Purposely Locking windows (Win Key + L) before the issue starts, instead of letting windows automatically shut off my monitors has the same results- windows still shuts off the monitors, but only after 1 minute with the session locked.

Closing iCue before I walk away, or before Locking my session does not prevent this. When I open iCue back up, RAM signal will immediately be dropping. Even if not, I shouldn't have to constantly be manually closing and launching iCue any time I walk away.

When signal is getting inconsistent, 99% of the time it's just on RAM stick #1. Very rarely it'll be #1  and maybe a 2nd or 3rd stick. These label #'s are what iCue has them labeled as on the DIMM Setup page. In reality, #1 is slot A1 and #4 is slot B2.
I have moved RAM sticks around, multiple times. I have, at any one point, had all 4 sticks in the A1 slot and the issue stayed with slot A1, not following any particular stick. I would assume this rules out having a faulty stick of RAM?

To my knowledge everything is completely up-to-date, and I have always kept things as such. Mobo BIOS is most current, same with iCue and AC. Every time there is an iCue update I COMPLETELY remove iCue via the "Clean Uninstall" instructions from Corsair. Then I make sure Armoury Crate is completely up-to-date, then I install the current version of iCue.
SOOOO, "do a clean uninstall and reinstall icue" is not a solution here....I've done this at least 20 times or more. When I noticed this problem, I started doing all different clean installs in different methods and orders of all the softwares even if there wasn't an update. "Force Update" on the RAM doesn't help, and usually doesn't even work once signal is lost.
I am making a backup and then Copying the CUE4 Folder (from ...AppData\Roaming\Corsair) back in every time I reinstall since that has all my custom curves, lighting, etc. all there rather than tediously Importing and setting up every profile everyt time. Since the CUE4 folder only has user settings and stuff in it, I don't think there's any issues with doing so?

Restarting iCue does not fix it. If signal is already completely lost, I can close iCue, relaunch it, close it again, then launch it a 2nd time in order to get signal back, but it will immediately be inconsistent until eventually completely drop again.

If I change my Windows Power Settings to always leave the monitors on I have no issues, even if I use (Win Key + L).
If I'm in a game or anything for hours, even walking away and leaving the game running for hours, no issues.
Very rarely, sometimes (usually while gaming) iCue might crash and close itself completely. When I relaunch it, I have no issues with the RAM signal.

So....this issue seems directly related to windows going into a standby mode that shuts off signal to the monitors.
I don't like leaving my monitors on when I walk away for a lot of reasons, so just disabling that in Windows isn't really an option.

ram signal 2.jpg

ram signal 3 big drop.jpg

Ram signal all.jpg

ram signal.jpg

Edited by wombler
Link to comment
Share on other sites

  • 1 month later...

Since I didn't get any any feedback from here I did create a support ticket, took them about 2 weeks to get back to me. But, turns out I had an issue with the Corsair Plugin for Aura Sync. See this- How to Integrate Armoury Crate with iCUE
While I did have that Plugin installed a long time ago following that guide, I had actually forgotten all about it, so never thought to redo anything regarding it. (And I feel like I read on some iCue update notes for a previous version that this plugin was no longer needed, but that obviously must have been something else)
I uninstalled Armoury Crate with the AC Uninstaller Tool, rebooted, then launched the Corsair Plugin install, which did tell me it was already installed but gave me an option to Repair or Remove. I chose to Remove the Plugin rather than Repair, then I Installed it, rebooted, Installed Armoury Crate, checked for updates in AC, rebooted. And all seems to be good now!

Link to comment
Share on other sites

  • 2 weeks later...

I doubt many people are currently following this, but I'm just going to keep updating in case someone else starts running into the same thing.

So, my last post was made too hastily and the issue is NOT resolved. Within a day later the problem had returned. Still working with Corsair Tech support as they have never seen this issue before (yay me!).
With their suggestion, I tried uninstalling MSI Afterburner, RivaTuner Statistics Server and Core Temp, as these are the only other "logging" software I run. That did nothing, so Corsair RMAed my RAM and sent me an advance replacement set. 
Replacement set didn't change anything. So I'll post back when we have any more progress....😔

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...