Jump to content
Corsair Community

Virtuoso RGB XT suddenly completely unresponsive. No sound and no charging light.

Recommended Posts

I just submitted a ticket to corsair. But since I know it can take a few days to hear back I am gonna copy paste here what I wrote in my ticket to see if anyone has any ideas on how to fix this/has the same problem.

My headset suddenly stopped working without any clear signs as to why about three days ago. No sound would emerge when turned on to wireless mode or when plugged into the computer by using the cable. When I used Bluetooth to pair it to my phone it would show as paired and the buttons would work to raise and lower the volume however no sound would emerge.

I also notice that the USB dongle is flashing red. When I tried to pair it again to the headset using Icue I noticed that the headset does not appear on the list of devices even when it is connected with the USB cable that came with the headphones. I have tried both resetting the computer and repairing the icue app using device manager but it does not show up.

The only way I am able to get sound to play through the headphones is by using the headphone jack adapter that came with them. However, when using the headphone jack no sound is picked up from the microphone, and if there are no sounds playing I can hear static in the headphones.

I tried the "How to fix an unresponsive virtuoso headset" guide and it didn't work. I made sure I tried it multiple times but nothing happened.

Another thing is that the small light that indicates the charging status does not light up. Even when it is plugged in, however, this doesn't mean the headset is dead as I can still pair it through Bluetooth, even though no sound comes out.

I spent the past three hours trying to troubleshoot and fix the problem by going to the corsair forums looking for an answer but nothing that I tried worked.

The headset is relatively new as it was purchased on May 27, 2022. And so far I haven't had a single issue up until now.

I am not sure if this will help but here's a list of the things I have done to try to fix it.

1. Plugged in the headphones to let them charge for an hour.
2. Following the directions in "How to fix an unresponsive virtuoso headset"
3. Repairing and reinstalling the iCUE app/making sure it was updated.
4. Deleting the headset drivers from my computer and restarting my computer.
5. Used Bluetooth to try to connect to different devices, and though it connected no sound came out.
6. Tried different USB cables to see if the problem was the cable, however, none of them worked.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...