Jump to content
Corsair Community

ICUE not opening after update to 4.38, only 3.38 works now

Go to solution Solved by Dari,

Recommended Posts

I updated ICUE to 4.38 version but it won't open, I tried repairing the app, doing a clean reinstall, etc but it still won't work. I finally tried installing 3.38 version and it works like a charm so it's clearly not a problem of communication between my software and hardware. Is there a way for me to fix this so I can go back to the latest version?

Link to comment
Share on other sites

After Update to 4.31***

Link to comment
Share on other sites

  • Solution

SOLVED: The uninstall was not removing all the files. Had to kill the Corsair files from %appdata% in win + R and also the remaining Corsair files in Program Files on my hard drive, after a reboot and a reinstall the problem was fixed

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...