Jump to content
Corsair Community

MP600 Pro XT 2TB extremely slow reads on *OLD* files

Recommended Posts

I have an MP600 Pro XT 2TB that is experiencing very slow reads on old files that have not been accessed in several months.  The read performance is horrible: 10 to 20 MB/s:


Once I have read an old file and then read it again the performance is excellent.  

Trim is managed by Windows.  I have optimized it and there is no improvement.  Fast boot is turned off.  The drive is only 60% full.  The drive is running cool - 36C.  I disabled Windows real-time protection and am not running any other AV.  I am using the latest firmware - EIFM31.3 on the SSD.

Benchmark performance is excellent:



Why is the performance so bad when reading old files that have not been recently accessed?

Edited by chrispie
Link to comment
Share on other sites

  • 2 weeks later...

Mine has gotten significantly slower on all files and extremely slow on writes.
I'm talking single digit megabytes per second. Also "Active time" in Task Manager is constantly at 100% and everything on the entire computer grinds to a halt. I've only had this drive for one year.

It's about 84% full, but I've never had an SSD slow down this much, even when 90%+ full. 
I've deleted enough stuff and retested with 58% full, but it only worked correctly for a short time.
It might be defective, so maybe not related to your issue.

Have you had any luck finding a fix for your problem?





Edited by thedoginthewok
Link to comment
Share on other sites

That is pretty bad, I'd be concerned about losing that drive.  I have not had any performance issues with writes.  The reads always speed up for me after re-reading a file.  But that is not why I bought this SSD.  Super disappointed.  I am going to replace it with a Samsung.  I submitted a support ticket to Corsair two weeks ago and have not heard back.  Did you try their suggestions here ?

Link to comment
Share on other sites

Yeah, mine is defective.
Right after my post I shut down the computer and tried turning it back on and the SSD was not detected by the Mainboard anymore. I've tried a couple more times and it's detected and "working" on about every 10th cold boot.

I'm creating an RMA request right now.

I've got trim running daily and fast startup is disabled.

Good luck with your support request.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...