Jump to content
Corsair Community

RGB lighting switching on and off randomly

Recommended Posts


Been having an issue with the RGB lighting on my system, Namely the RGB Lighting on the CPU, Cooler and Front fans, all switch off and on, with the "bleep" that goes with  a USB being plugged in and out, they switch off only for a few seconds and I can't be sure if the fans actually stop as well, the lights going off, doesn't really bother me, Its the constant "bleeping" that goes with it, but, also if the fans are shutting off too, that's a bit more worrying, the RGB on the Main rear fan and on the RAM do not go off. 

It's a prebuilt system, less than a year old, ASUS Z690 Prime, with i9, 64gb ram, 2x1tb SSD's and 1x4tb SSD,  Nvidia RTX3090. 

Link to comment
Share on other sites

I am having the same issue with a brand new Origin build with the Asus 670E Hero with Corsair iCUE H150i ELITE CAPELLIX Liquid CPU Cooler, AMD 7950X with 10 QL RGB fans in total.

Throughout the day, I keep having disconnects. There will be the USB connect/disconnect chime and then the Capellix Unit and fans will power off for a second and then kick back in. Sometimes, I'll notice that the other 6 fans do that as well. Also, I noticed when I was doing a large file transfer to a thumb drive attached to the case's top USB port, that lost connection as well.

This is a brand new build and cost me a lot of money. The support at Origin has no clue even though there are loads of posts about these disconnect problems online with Corsair/AMD combos. Even though there are loads of posts about the problem, I haven't been able to find any kind of definitive fix for this issue.

Origin is saying that I should send it back so they can test it. I just got all my software installed and really don't want to deal with the shipping back and forth and waiting on this, especially since I have to use this PC for work. They were supposed to stress test and observe for a period of time before they even shipped it out to me in the first place. How do they miss this?

Does anyone have any suggestions for a fix? I have tried adjusting power settings and re-installed Icue, installed latest chipset drivers, BIOS, etc. I also checked to make sure the internal USB connections were seated properly. I don't know what else to do at this point.

I'd appreciate any suggestions. I can't believe I'm having issues like this on a brand new PC that cost me almost $6K. I didn't want to build my own PC but now I'm stuck spending hours and hours researching this crap trying to find a fix.

Link to comment
Share on other sites

4 hours ago, poesprogeny said:

new Origin build with the Asus 670E Hero with Corsair iCUE H150i ELITE CAPELLIX

The original issue is here.  https://help.corsair.com/hc/en-us/articles/360057420751-What-to-do-if-your-Commander-Pro-loses-USB-connection

Most users on those boards solved the chipset allocation issues by setting PCI-E gen 3 or using a powered USB 2.0 hub to help maintain voltage stability at the socket.  There have not been a lot of reports on the X670 platform, but it's possible there will be the same compromises made when moving these boards to PCI-e gen 5 in "selective" sections.  Try setting PCI-E to gen 4.  If that does not work, then the powered hub would be the most logical next step. 


As an added measure, the Elite Capellix series can be a bit finicky all on its own.  Do a full power down, PSU off, then deliberately disconnect and reconnect the wide power cable on the side of the Commander Core making sure the white stripe is lined up.  A lot of users don't quite get this fully engaged and it can cause this issue.  If you have the LCD top version, pop that off as well and reseat.  Flip the PSU back on and restart.  The PSU off cycle forces the Com Core and pump to do a full check on the next power on.


Link to comment
Share on other sites

16 hours ago, Brian510 said:

less than a year old, ASUS Z690 Prime,

Similar to the AMD issues moving to gen 4, the Intel Z690 had a similar issue.  However, unlike the AMD chipsets the powered USB 2 hub most often did not help.  If you have one lying around --- great, give it a try.  Otherwise the most successful solution for other users have been to use a USB 3 ->2 internal adapter cable.  Most boards have 2 internal USB 3 and most users won't need 4+ USB 3 ports on the front of the case.  If you do, then you may need to try something like a USB 9 pin internal to USB A adapter for the rear motherboard ports.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...