Jump to content
Corsair Community

ICUE - Hard Locking Timer Resolution Issue

Go to solution Solved by Kokkatc,

Recommended Posts


I recently purchased the Corsair k70 rgb tkl champion series optical keyboard and absolutely love it.  The problem is that my timer resolution is hard locked to .5ms after I install ICUE w/ no way to change it.  ICUE is overriding any timer resolution app I use (ISLC, timer resolution, etc).  This unfortunately is a game breaking issue since the primary game I play does not behave well w/ a .5ms timer resolution.  Nonstop stutter, high cpu usage, etc.  It needs to be 1ms.  Also, I don't want my system running at .5ms when I'm not gaming.  

I've tried closing the ICUE app and every Corsair related background service/process w/ the hope that ISLC or timer resolution or my game will allow the system to change the timer resolution back to default or 1ms but nothing works.  The only way to regain privileges to changing timer resolution is by completely uninstalling ICUE.  

Anyone have any fixes for this or suggestions?  I'd hate to have to return my keyboard because of this.  Also, will my keyboard retain its settings if I install ICUE, configure my keyboard settings and then uninstall ICUE?  The only settings I really care about is the keyboard's refresh rate / hz.

Link to comment
Share on other sites

  • Solution

I found the solution to this problem and wanted to post what I found in case others in the future run into the same problem.

Coaing the ICUE software didn't work.  Timer Resolution was hard locked at 5ms, so I opened up task manager and closed anything related to Corsair.  This didn't work either.  Next I went to look at services and turned off  / disabled each corsair related service one at a timw to see which one was hard locking timer Resolution to .5ms. Turns out it was the Corsair LLA Service.  Once this service was turned off and then disabled, other apps on my system were allowed to change timer resolution again.

A for anyone that doesn't want ICUE to hard lock your timer resolution service, turn off and then disabled the Corsair LLA Service.  I believe it controls the DRAM software lighting mode from what I researched online.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...


Well i found this issue also. Idk why corsair wants to mess with windows's default timer res. - causing problems to other applications.
Do you also notice a big difference ingame (i mainly play csgo), when LLA Service is forced off via services?
I wonder if its the same effect, as keeping icue uninstalled.  I wish Corsair could fix this Issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...