Jump to content
Corsair Community

Corsair HX1000i Won't Provide Power for More than a Few Seconds

Go to solution Solved by CyberB,

Recommended Posts


I have a HX1000i that I am having problems connecting to an older motherboard, ASUS STRIX Z-390E and using this with a ASUS TUF 4080 video card.

The video card gets power (red light ).  However, when I try to power up, the system seems to come up for a few seconds and then shuts down.  The only way to re-power is to then toggle the power switch on the supply. 

I tried removing the 4080 video card and going back to my original setup with a NVidia 1060.  The only difference here is that I removed a EVGA 750 and replaced it with the HX 1000i.  The HX1000i won't power this either - it starts to boot and shuts down in a few seconds.

Admittedly, I left the same connections for the AIO cooler and fans and just plugged these in to the new supply.

Any thoughts?

Link to comment
Share on other sites

Did you use the EVGA cables or the corsair ones?

If you used the EVGA, you are most likely triggering short circuit protection on the PSU, since the pinouts are different from brand to brand

You'll need to use the corsair cables.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...