Jump to content
Corsair Community

Can't change Founders Edition RGB

Recommended Posts

Hey all,

I've recently bought myself a 3090 founders edition and want to change the lighting on the card, but seem to be having problems with iCUE. The half triangle on the top of the card will only be green, and the logo on the side (I know can only be white) but it is locked at 100% brightness. 

There is nothing that makes changes to the colour bar on the top of the card, non of the pre-sets change it, setting a solid colour either does nothing or the colour does change when on the colour pallet but then instantly changes back to green. This is the same with the logo on the side, I pull the slider it does make changes but as soon as no changes are being made its back to 100%. 

(For a little insight) I was using an older iCUE when I first installed the card and it was behaving the same, didn't even know that there was a newer iCUE, but downloaded iCUE 4 and its giving me the same results. I don't know if this is an iCUE problem or there is something else cursing this. The only other software I have for RGB is RGBFusion for my motherboard which has no control over the lighting on the GPU.

I've seen on other posts that people do have problems with RGB within iCUE, but my friend picked up a 3080ti founders edition for himself and has full control of the lighting on his card with iCUE where I have 0.


Any help is greatly appreciated. 


Link to comment
Share on other sites

  • Corsair Employees

Close down the RGB Fusion software completely, right click on the iCUE desktop icon, and click on run as administrator. See if that resolves your issue.

Link to comment
Share on other sites

Hey, I don't run RGBFusion, only needs to be open to change the colour, I also tried running as administrator and no luck there. 

Wanted to ask, do you know if Geforce Experience has any control over the cards RGB, as with iCUE set to not launch on start up, the card RGB is white until my Nvidia control and Geforce Experience load then the card goes green. But to my knowledge Geforce Experience dropped RGB control a long time ago, and I can't find anything in the modern version about RGB.  

The only things I have on start up is my audio stuff and the Nvidia programs (and iCUE but with it disabled I still get the same result).

Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...