Jump to content
Corsair Community

iCue stuck firmware update

Go to solution Solved by c-attack,

Recommended Posts

I have the latest version of iCue installed and when run it says I need to do a firmware update to my M55 RGB Pro Mouse.
I click the update button, which is barely visible at the bottom of the tiny popup.


It then displays this message - and after that I can not press anything on the software to proceed.

the message box is cut off so I don't know if there is a button further down to initiate the update.

Any assistance on how to proceed would be most grateful  as the iCue software is totally unusable now.
Why are the popups so tiny, that they cut off the actual message.

I have tried reinstalling iCue, moved to different monitors 4k, 2k and 1440p to try and see the rest of the message box but all to no avail.
I wish we could just download firmware separately as having to go through the buggy iCue software is frustrating


Link to comment
Share on other sites

  • Solution

There can be a lot of reasons for the update to hang, from VPN or usb hub issues on your side to server issues or software problem on their side. Unplug the mouse or force restart the PC to get out of the current bind. Then I would reset the mouse with the procedure described below. See if that allows you to continue. Don’t try to do this through a KVM switch or other usb hub passthrough/hub. 



If that does not work, leave it alone. There is no critical firmware update that will prevent you from using the mouse if you don’t update right now. On the other hand, bricking the mouse by continuing to try and fail will prevent you from using it. If this is a server side issue for them, all you can do is wait. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...