Jump to content
Corsair Community

The RGB lights on my PSU suddenly stopped working


Nexgen
Go to solution Solved by c-attack,

Recommended Posts

Greetings,

My build is brand new, it was literally the second day I was using my computer and the RGB lights on my PSU stopped working for no apparent reason.
What I did before : turned off the computer, did some cable management, un-plugged (accidentally) the little rgb cable that connects my PSU to the motherboard on the 'JRGB1' plug. I putted back in its place where it was (JRGB1), then... no more RGB lights every since I turned the computer on.
Something I noticed is that the little RGB cable (iCUE RGB) is loose, when I plug into the "JRGB1" plug of the motherbard, it take a very few efforts to take it out. Could that be the problem ? Weak contact or no contact at all ?

My system :

Intel Core i5 -12400
ASUS Dual Radeon RX 6400 - 4GB
Kingston Fury 2x16 GB - DDR5 - 4800 Mhz
SSD Kingston 480 GB - M.2 -  PCI 4.0

MAG B660M Mortar (MS-7d42)
CX550F Corsair - White - 80Plus

The RGB cable was plugged on the motherboard since the beginning, everything worked fine. 
I haven't used any software for controling the RGB whatsoever, but, after the lights went off, I downloaded, installed and used the iCUE software 

to see if I can do something about it but, the PSU would not be recognized by iCUE at all. (I guess the PSU must be plugged on to the iCUE Commander Pro smart RGB)
I tried the MSI software for controlling the RGB lights (since my motherboard is MSI and the PSU is connected directly on it) but here neither my PSU would be detected. 


PS : the PSU is working fine, such as the rest of the components, everything seems to be stable, it is really just the RGB that got kidnapped I hope we can find and bring them back home.

 

1.jpg

2.jpg

3.jpg

Edited by Nexgen
Link to comment
Share on other sites

  • Solution

You are using the wrong cable and I’m afraid the wrong motherboard header. That cable is for connecting the PSU to a Corsair RGB controller. The cable to right of that on the box is for connecting it to the motherboard. 
 

JRGB1 is a 12v header. The fan LEDs on the PSU are 5v. You may have fried them. You need to use the “motherboard ARGB” cable and connect to JRainbow (MB 5v digital RGB header). Fingers crossed. 

Link to comment
Share on other sites

Thank you c-attack for your reply, so I was using the wrong cable... I followed your instructions and used the motherboard ARGB cable and connected it to 'JRainbow' .

Unfortunately, the LEDs won't turn on, it's over. Thanks for taking your time, I wish I knew this earlier.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...