Jump to content
Corsair Community

Flash Voyager not recognized


danielwchin

Recommended Posts

I bought a 512MB Flash Voyager in January from Tiger Direct. Not long ago, it started to get flaky--only mounting if I held it in the port just right. Then it started to give me errors saying it wasn't formatted. I was able to use a data retrieval program to get the data off of it and format and rebuild it, but it happened again the next day. After doing that a few times, it doesn't work at all, though fortunately I had the presence of mind to also keep a copy of my data elsewhere. The little blue LED doesn't light, I get no USB notifications, nothing. Other USB devices work on my computer and I have the most current firmware and drivers for my motherboard. I've also tried the drive on three other machines with the same result: nothing. I took it back to Tiger to see if they'd help me, but it was passed their 30 return policy. What can I do? Thanks in advance for the help. Oh yeah, I'm running Windows XP Pro.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...