Jump to content
Corsair Community

Registers wrong temp for cpu and coolant (H150i elite lcd)

Go to solution Solved by c-attack,

Recommended Posts


When I download the software and start using it, it registers the wrong temperature on both cpu and coolant. (I have a H150i lcd). This also occurs when I have just started the PC, then it rises to approx. 95 degrees celsius for the cpu and 65 - 75 degrees celsius for the coolant within a couple of minutes. It also causes the fans to go up to max and won't calm down.  

The air coming out of the radiator is freezing cold, to the point where I'm freezing. When I haven't downloaded icue, the fans behave normally and the lcd shows normal temperature (at least as far as I can tell). When I check the cpu temp in the bios, it shows approx. 30+ degrees, while icue goes haywire. 

 I have tried to download the software 3-4 times and this happens every time. I have also formatted the PC.  

After it has been running icue for a while, the rest of the system also starts to be laggy. Any tips? I really want to be able to have icue installed, as I have invested some money in rgb. 

Link to comment
Share on other sites

  • Solution

Are you getting a "pump fail" error from CUE after install?  If the pump was not circulating water, the small bit trapped in the block would slowly heat to 65C over several minutes and put the CPU temperature at 5-30C above that depending on voltage state.  This is what you would expect with a dead pump, but it should also trigger a CPU boot error from the BIOS and the pump fail notification in CUE and likely a (!) on the LCD top.


It also should not only do this when CUE loads.  A dead pump is dead and doesn't respond from the moment the power goes on.  Another user recently reported a similar condition, with it appearing to work fine until CUE loads.  The LCD top can complicate things.  Try the standard remedy of power down, PSU OFF, the disconnect the wide power cable on the Commander Core then reconnect.  Then pop the LCD top off and reconnect.  My best guess is the handshake on CUE load is failing (physical or software) and this causes the system to lock up.  The power cycle forces the components to do a full re-check which might help the physical.  If this is a software issue, I don't have any suggestions.

Edited by c-attack
Link to comment
Share on other sites

  • Corsair Employees

Also do you happen to be running other hardware monitoring software alongside iCUE such as HWiNFO, AIDA64, HWMonitor, etc...?

Link to comment
Share on other sites

  • 2 months later...

Hello, and sorry for such late answer . I did what u said and it worked to unplug all the cables.  It has worked perfectly fine ever since. Thank you so much for the help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...