Jump to content
Corsair Community

Cannot Create/Clear/Update Hardware Profiles (Scimitar RGB Elite)

Recommended Posts

I'm at my wit's end with this device/software. Every time I restart my computer/every time I unplug and replug my Scimitar RGB Elite into my PC it automatically copies these weird Japanese onboard profiles into iCUE. 

In the latest version of iCUE 4 I cannot delete nor replace the hardware profiles. Pressing on the 'clear' or 'overwrite' button simply does nothing, or occasionally the software just hangs and after an hour or two I have to force close it. One time, I don't recall how, it managed to overwrite one of the profiles, however, it was replaced with Japanese characters and the foreign profiles again at next start up. 

I have tried soft resetting the mouse. I have uninstalled and reinstalled drivers and iCUE. I have repaired iCUE. I have removed iCUE4 and tried with iCUE3. With iCUE3 it will let me clear the profiles, however, if I try to write profiles to the onboard profile slots they appear in japanese characters, and they keep getting copied back into the main iCUE profiles. 

It's madness. I just want to be able to remove whatever foreign profiles are on the device and replace them with my own.

iCUE Profiles.png

iCUE Profiles2.png

Link to comment
Share on other sites

Not sure what to make of this.  Educated guess it this was intended for different market.  The 'soft reset' puts it back in the original factory state, so if that was for the Asian market I can see why they would come back.  I don't understand why it writes them back to CUE in that language after you save your HW profiles to the slot.  If you delete the HW profiles from CUE, it will repopulate them each time as you've seen.  The inability of CUE 4 to properly save to the slots is a different issue and they are other reports of this problem with various KBs and mice right now.


Have you tried to force update the firmware?  Clear the onboard memory in CUE 3.  Then go to CUE settings for the mouse, check for update -> None.  Then "force update" should appear.  See if that clears this up.  There are not individual device language options, just the overall one for CUE, so if this doesn't work I don't have another recommendation.  Definitely start a Support Ticket with Corsair if this unsuccessful.  There have been a few KBs with language issues, but I can't remember this on a mouse.  

Link to comment
Share on other sites

Hi, thanks for the reply. I've tried soft resetting many times and noticed that sometimes I'm getting different profiles. Also it will sometimes revert to the right mouse button being the primary click (which I suspect may be the Asian market thing again?) 

Either way, I don't know what combination of having icue running or not running, and using icue 3 vs 4, and whatever else was happening on my PC at the time, but out of no where when I soft reset it sometimes it reverts to english named profiles.  Almost like it has both Asian and international states on it, and it can soft reset to one or the other??

In any case, once it reset to English I could remove the profiles and replace them as expected. I suspect issues may return, in which case I will try force updating the firmware, but for now at least the Japanese characters have stopped appearing and things are functioning better. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...