Jump to content
Corsair Community

Vitruoso RGB headset not detected via dongle or wired after 4.31.168 update.


Recommended Posts

Ive been using the Vitruoso RGB headset for almost a year. Everything was working smoothly. Then the Update 4.31.168 made it stop working. 
I have tried uninstalling/ reinstalling. I have also tried a clean uninstall/ reinstall. 
Headset is fully charged and lights up when attempting to connect in wireless mode. When plugged in directly it is just charging it. 

My computer detects the connection of the dongle, but won't connect wirelessly. Nor, does it detect the headset if plugged in directly. 

I looked for the audio drivers and they don't appear. 
I checked the USB controllers, When i plug in the Headset directly It says:  Unknown USB Device(Device descriptor request failed)

I dont know what to do at this point and feel like I have tried everything

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...