Jump to content
Corsair Community

2/3 front fans work with rgb not working or being detected by ICUE.


Recommended Posts

I have a corsair spec delta that uses the 3 front fans and one rear fan.
the rear fan doesn't work and the middle fan doesn't either they both haven't worked since I've built it.
I plugged the 3 front fans into the rgb splitter that came with the case into this 12v pin but I still have no lights and my 3rd fan is still stationary.

image_2022-12-16_170820513.png

Link to comment
Share on other sites

  • Corsair Employees

The RGB control for the fans is going to be through your motherboard RGB software since it plugs into the 12v RGB header on the motherboard via the adapter. The fans then require the 2nd connector that isn't the RGB cable to be plugged into fan headers on the motherboard and RPM control is via the BIOS or motherboard software as well.

Link to comment
Share on other sites

what do i do for my third fan that doesn't work should i get a fan hub or is it beyond repair

Link to comment
Share on other sites

I've also downloaded my mobos rgb software (rgb fusion) and it shows its on but theres no lights/rgb coming from it

image_2022-12-17_131906330.png

Link to comment
Share on other sites

  • 3 weeks later...

will a fan hub fix this issue and will it allow me to use the rgb features

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...