Jump to content
Corsair Community

iCUE not showing any device/sensor on a completely new build - H115i Elite Capellix


Recommended Posts


I finished instaling the cooler today, along with the iCUE Commander and so on, and after installing the iCUE software, the latest version, the screen comes up empty: no sensors are displayed.

I have checked and rechecked the connections, moved the Commander USB to another port, installed previous versions (4.26 and 4.29) with no luck.

The Windows is Windows 11 Pro for Workstations, has all the updates, and it is a fresh install.

I had installed the MB software to monitor the CPU temp (I installed an air cooler before, while the H115 arrived) but have already uninstalled everything related to that with no change whatsoever.

What I have found on the internet hasn't worked. Most solutions are to install the newest verision or change the USB port, but neither changes anything. The cooler is working, I mean, the fans are spinning, the pump is running, but I would still need to tweak the settings, and monitor the temps! Without sensors I can't do neither.

The only Corsair hardware I have in this computer is the cooler and a AX860i PSU, which I already disconnected the Corsair Link dongle to see if that was the issue but didn't work either.

Any ideas?

Link to comment
Share on other sites

What is the motherboard?  Chipset seems to be the dominant factor with this and some specific boards have trouble recognizing the USB 2 internal connection.  The 860i is a relatively low needs device and usually detects well.  The Commander Core is more needy and boards that cut corners on the voltage to the port sometimes have erratic connections.  Make sure you have installed the chipset and/or IO driver set for your motherboard.  You don't need to swap CUE versions or uninstall random software.  This is an initialization issue.  

Link to comment
Share on other sites

Thanks for your reply.

The motherboard is a Gigabyte Z690 UD AX DDR4. It only has 2 internal USB2 ports, and I have tried in both.

All the drivers for the motherboard and chipset are installed. Windows doesn't show any unrecognized device. In this same line, I also don't see anything that reads "Corsair" in the USB section of the device manager. I don't know if I should see something there, but I'm guessing that is the problem. With the PSU dongle there is a Corsair device listed there.

Link to comment
Share on other sites

The AMD x570/B550 boards had the voltage drop issue.  The Z690 was just mysterious.  Lots of user issues getting stuff recognized.  I suspect there were some odd workarounds cramming stuff into the new chipset at the expense of the USB 2.0 ports and it's interesting we haven't seen these complaints at all on Z790.  


Here is the Corsair troubleshooter page.

https://help.corsair.com/hc/en-us/articles/4404450662285-What-to-do-if-your-Corsair-device-is-not-detected-on-startup-or-after-waking-from-Sleep-Mode#:~:text=If your connected Corsair devices,device into the USB port.


However, many users have required a physical solution.  The most consistent workaround has been to use a USB 3 -> USB 2 conversion cable.  Unfortunately that means you lose one of the USB 3 internals but most boards have 2 and you may not need it.  Another possible option is to use a USB 9 pin internal to USB A cable adapter so you can route it around to the IO.  

Link to comment
Share on other sites

  • Corsair Employees

Have you tried to use a non-workstation build of Windows 11?

Link to comment
Share on other sites

  • 4 weeks later...

I've just received the USB3 -> USB2 adapter. I connected the cable there, reinstalled the software, and it is still the same. No devices at all are being shown in iCUE.

I'm guessing it's going to be more a software problem than a hardware one. I don't have a cable to connect to the back ports (the adapter plugs into the front USB3 port in the MB) but now it's 4 different USB ports that have been tried without any difference, and the USB3 ports I am sure work without problems, as I used them before...

Anything that I can try to provide to Corsair for them to find this? Or I just give up and live without the software? I could probably still try to return the whole unit and change brands, but that's maybe too extreme...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...