Jump to content
Corsair Community

New Corsair Vengeance RGB RAM not getting detected by ICUE


Recommended Posts

Hello, some weeks ago I bought the "Corsair Vengeance RGB, DDR5-6200, CL36 - 32 GB Dual-Kit" the RAM is working as expected besides the lighting which drives me crazy!

I am not able to Control the lighting at all as the RAM is not getting detected in the ICUE software,its not even listed in the device section.

I tried so many solutions I found at the internet, nothing worked!

I just installed the latest update for ICUE some minutes ago and still.....nothing!

Only on "Sensors" it is atleast saying something with corsair as RAM.

I was even sending it back as RMA to the shop where i got it from because i have seen the post in this forum that there where faulty RAM models released, I told them that , they checked it on their test bench/setup and it was working as intended for them so they send it back instead of replacing it for me!!

The problem seems to be software/driver related i guess.

Im really starting to get mad at this point, I bought this RAM as my G.Skill Trident Z broke twice in 3 month and is currently send in to the manufacturer, now im getting new ram to replace these and those are faulty again... these things are not cheap so i expect them to work?!

Has anyone an idea whats going on here?

I hope someone has a Solution, thanks in advance!




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...