Jump to content
Corsair Community

iCue 4 cwon't open on new PC

Recommended Posts

I just got a new PC a few days ago and I've been trying to install iCue 4 to no success.  I have uninstalled, restarted my PC, tried repairing the app, running as administrator, everything I can think of trying to get the program to stay open for more than 2 seconds. Every single time it will open then almost immediately crash, and then also crash my mouse and keyboard (k70 and a wireless DarkCore) as well so I have to plug them back in to get them to work again. I can't get the program to stay open long enough to make any setting changes, it just immediately shuts down. I don't have any other software installed that would conflict (RGB Fusion, Mystic Light, Aura Sync, etc). I've even tried using older versions of iCue 4 and the same thing is happening (maybe I'll try iCue 3 instead). I have been able to isntall iCue 4 on my Macbook so I'm guessing this is a Windows only issue. Everything is up to date, and I haven't had the PC long enough to have any viruses or corrupt files. 

Any help is greatly appreciated. I just want to set my macros and mouse's DPI. 

Link to comment
Share on other sites

Same here, My icue 3.38.88 was starting to do the same thing.  I finally upgraded to the newest icue 4.  If I open it from the windows menu, it opens for a second, then closes after roughly 3-4 seconds.  I cant get it to stay open?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...