Jump to content
Corsair Community

K55 RGB no longer functions after updating ICUE to 4.30.162

Go to solution Solved by TheEggman17,

Recommended Posts

I have had this keyboard for a while now. Today I updated ICUE for the first time in a while. Ever since then my keyboard will light up however none of the keys work. It shows up in ICUE with a red hazard symbol "Unavailable". 

What I've tried: 

Holding down Page Up and Page Down then plugging into pc. This semi works as I am able to update the firmware successfully, per the message in ICUE. The keys still no longer detect input. 

Then when going into settings it states the update failed. 

I can not find anywhere to manually download drivers. 

I am stuck on what to do further. Suggestions? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...