Jump to content
Corsair Community

Unable to Install latest iCUE or Uninstall previous version - totally stuck

Go to solution Solved by John Hoang,

Recommended Posts

So the last version I had installed was 3.38.88 and I am trying to upgrade to 4.30.162

Anything I try gets the dreaded "Error applying transforms. Verify that the specified transform paths are valid." error message.

So far I have: -

1) Run the Microsoft install/uninstall checker - if found nothing wrong.

2) Unregistered and re-registered the Windows Installer - did not fix it.

3) Run DISM.exe /Online /Cleanup-image /Restorehealth followed by sfc /scannow  - neither of these found any issues.

4) Downloaded the original v3.38.88 MSI installer file and tried a MODIFY, UNINSTALL, and an INSTALL - none of these options worked.

5) Manually deleted ALL Corsair/iCUE files and Registry entries from my system


Please can someone help as I now do not have a working iCUE software and I have a load of Corsair devices (keyboard, mouse, mouse mat, etc.) which are now doing nothing.

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...