Jump to content
Corsair Community

iCUE causing lagging shutdown. Won't update RAM Firmware.


Recommended Posts

Hello all, I am having a strange problem. I just had my RAM RMA'd because the RGB wouldn't sync or be recognized. Received the new RAM and the RGB works great. Now if I go to the system tray and turn off iCUE, it lags out Windows for about 4 minutes and will shut off my monitor. It also makes windows lag heavily when I shutdown the PC. Another thing I noticed is the RAM says "Update Failed" and when I hover over the information icon it says "Firmware update is unavailable." 

I was just curious if anyone has had similar problems. There is no other lighting software installed and I also tried turning off the "Lighting" service in services but still no fix.

iCUE v 4.30.162

Vengeance DDR5 v 0.07.5

Link to comment
Share on other sites

  • Corsair Employees

There is no firmware update for the for the memory. The update failed error when you attempt to update the firmware is an bug as it should be be letting you know there is no update, or that the memory is already fully updated. You state that you don't have any other RGB software installed but the LightingService service that you mentioned is going to be from motherboard's RGB software as that is not a service installed by iCUE. When you upgraded to the Zen 4 based system did you just carry over your boot drive from the previous? Or did you actually do a full wipe and clean install of Windows?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...