Jump to content
Corsair Community

CORSAIR SABRE RGB PRO PRO WIRELESS CHAMPION SERIES does not want to charge or turn on anymore ...

Recommended Posts

Hi everybody,

As I said in the title, I have a Corsair Sabre RGB PRO Wireless Champion Series who works perfectly fine until yesterday.

Today, I tried to turn it on but unsuccessfully. I was thinking that there is no more battery so I use a wire to charge it. Unfortunately, it does not work, the light of the mouse do not turn on and it does not charge.

I tried to use another wire, still the same (these wires works with other devices so it does not come from this).

I even tried to reset my mouse but as I said no light turn on so I did not know if the device "receive" the reset.

I don't know what to do, if it was the battery, the mouse is supposed to still work when I use the wire but it's not the case.

Thanks for you help,

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...