Jump to content
Corsair Community

Corsair iCUE H100i ELITE LCD liquid cooler won't show up in iCUE


Recommended Posts

Okay, so in april 2022 I bought myself some brand new components to build a decent setup, to this  setup I wanted an AIO that would look nice with the rest of my setup, so I bought the cooler listed in the title, and ever since I installed it, it gives me the triangle exclamation mark, sometimes it gives me the standard corsair gif if im lucky. I have been troubleshooting like crazy, removed all the programs I thought could interfer with iCUE (AI suite 3, Armoury Crate) Reinstalled windows, reinstalled the commander core, reinstalled literally everything. I have tried skipping the usb Y splitter, nothing. Also followed all the other steps listed on corsairs site. I also have a Corsair K70 that used to show up in iCUE, but it doesnt anymore, and the red lightning is gone, also cant use the raise volume scroll on it, or any of the other "extra" keys in the upper right corner. Don't know if its related to iCUE or maybe the keyboard is just getting old and its time to replace it. 

Oh yeah the commander core shows up in icue and there is no problem adjusting the fans installed on the radiator, so I dont understand what IM MISSING PLEASE HELP AAAAAAAAA

I've made a ticket aswell but they take years to answer so I might get lucky here you never know

k thanks bye<3

My specs:

Asus z690-p

Corsair Dominator Platinum DDR5 32GB RGB (works fine in iCUE)

MSI RTX 3070 Ti gaming X trio

i7-12700K

m.2 ssd 1tb      

750watt psu

Corsair iCUE H100i ELITE LCD liquid cooler

Link to comment
Share on other sites

There is a very long thread below and it’s the best place to look for solutions and get help from others with the same gear. 

 

The (!) is a generic warning signal representing several possible issues.  Most of the time it’s connectivity related.  Power down your PC and flip the PSU off.  Then disconnect and reconnect the wide 20 pin plug on the side of the Commander Core. I would check the usb 2 splitter between lcd top and Com Core while you’re there.  PSU back on and start normally.  The power cycle forces a re-detection.  If this does not work, you may have to look at how your usb connections are arranged and split the LCD top and Com Core to different connections.

 

I do not think the K70 is related and that seems like a keyboard issue.  Try the ESC key keyboard reset below.

https://help.corsair.com/hc/en-us/articles/360025465031-How-to-Reset-your-keyboard
 

 

 

Link to comment
Share on other sites

Probably means the USB is OK, but the device to device communication between LCD and Com Core is not working as expected.  This is a really messy issue and has been giving people fits for a while.  There isn't one solution and if the power reset didn't fix it, the door is open to a lot of other possibilities.  I would contact Corsair Support through the ticket system at the bottom of the page.  Resolution could require hardware replacement or specific firmware for specific model numbers.  

  • Like 1
Link to comment
Share on other sites

After doing everything you said, and then some. I think I made a small impact, its no longer the exclamation mark, its instead the standard temp screen, but stuck, and showing zero celcius. Does it mean anything? the LED on the screen still wont work or ever has tho

Link to comment
Share on other sites

Unfortunately that is another version of the same general problem. 0 or negative numbers were commonly reported and signify a communication issue between the two devices. Look at the end of that thread to see if there is any current advice, but most it will involve the power down, PSU off, and then re-seat the LCD top on the little connector on the pump/block. 
 

Definitely get on to Corsair Support as well. 

Link to comment
Share on other sites

Commander Core and Commander XT are sibling controllers with a fair bit in common, but they are not the same. The Commander Core was introduced with the Elite Capellix AIO series. In came in the box and was a necessary solution to the new OLED  top with no extra room for fan controllers or RGB control. So it went external and grew to 6 fans to make it useful for the standard 6 fan build. 
 

The Commander (Core) XT came later. It is the standalone retail version for fan speed and RGB control. It does not have the wide power port required to make the pump work. That is removed and you 2 temp sensors and 1 LED port instead.  However, with Corsair’s standard naming practice there is a lot of confusion on the name. People often say XT when they mean Core and vice versa. They should not have used the word “Core” in the Commander XTs name and I try to refer to it with out it. The XT is not really a “Core” device nor is it the same as a “Pro” with dual LED channels. Just Commander XT would have enough to distinguish.
 

I see 20/22/24 pin language used and I have probably said all three numbers at one time or another. I think this is more user approximation rather than actual variance.  What would be interesting is if there are only 20 pin holes on your pump connector end. 

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

@c-attack Hey, I have been in contact with tech support and it really seems like they only have automated answers and not actually reading the text I'm sending them. They want my Serial number on the cooler, which I know is on the side of the radiator, but I can't reach it without dissasembling literally the entire case. So I asked them, if the serial number on the LCD cap was enough, and sent it to them. Then they responded like this: https://gyazo.com/1aec597b5149e68ad7a61ab09de2edc5

I have looked everywhere, I don't have the reciept. Are they still able to help me even if I don't have the reciept, and is the serial number on the lcd cap enough? 

I'm not saying I won't dissasemble it if they really need the SN on the side of the radiator, I just want to know if it's worth it. Since I don't have the receipt.

Link to comment
Share on other sites

If you still have the box it will be on the white sticker with the part number (WW-…) and several others. The LCD top is technically a separate product and likely has a different serial number and lot code. I have doubts there is an issue with the Commander XT. The lcd top is more probable if there is a physical defect, but on the combo kit I’m not sure which they use for product tracking.

 

The receipt is a bigger problem. The purchase date both starts the clock on the warranty and also identifies you as the original owner. The warranty does not transfer to a second purchaser. You might be able to convince them the serial number and lot number identify this as a recent manufacture and thus the warranty cannot have expired. While logical, this may not be enough to persuade them on product replacement. 
 

However, that really should only matter if you are at the replacement phase. A purchase receipt is not required for general tech support and that is where things should start. If you are being denied tech support because of a missing receipt that is wrong and someone needs to get on this. 

Link to comment
Share on other sites

3 hours ago, c-attack said:

If you still have the box it will be on the white sticker with the part number (WW-…) and several others. The LCD top is technically a separate product and likely has a different serial number and lot code. I have doubts there is an issue with the Commander XT. The lcd top is more probable if there is a physical defect, but on the combo kit I’m not sure which they use for product tracking.

 

The receipt is a bigger problem. The purchase date both starts the clock on the warranty and also identifies you as the original owner. The warranty does not transfer to a second purchaser. You might be able to convince them the serial number and lot number identify this as a recent manufacture and thus the warranty cannot have expired. While logical, this may not be enough to persuade them on product replacement. 
 

However, that really should only matter if you are at the replacement phase. A purchase receipt is not required for general tech support and that is where things should start. If you are being denied tech support because of a missing receipt that is wrong and someone needs to get on this. 

Exactly my thought aswell... I don't want a replacement product, I don't want a brand new lcd cap/cooler. I just want some tech support so that I can get help with the goddamn software, which refuses to recognize my gear. Windows can detect it, and so can iCUE version 4.17xxx, so why shouldnt todays version be able to do it? I'm fairly certain there is  nothing wrong with the hardware... 

Yes, icue version 4.17xxx detects it, but unable customize.

 

I still have the box fortunately so I just sent the photo of the SN, and a text saying here's the SN now please give me tech support. Hopefully something happens now, been almost a month with nothing but useless replies....

Link to comment
Share on other sites

Hello again @c-attack! I finally got a response from the support, and they asked me to do this https://gyazo.com/79d1d4cf9a6e29755170c1afe975e5be

I have already stated, atleast three times in previous emails that I'm not using hubs/splitters. So what does he mean by plugging the AIO directly into the motherboard? Doesn't the AIO depend on the com core for it's power?

Link to comment
Share on other sites

Yes, support means to try connecting the USB for the LCD top and the Commander Core to the motherboard independently and not using the LCD top splitter that joins the two.  Corsair devices do not communicate directly with each other over USB, so that is a shared return to the motherboard path which is were a lot of the issues come in.  This is of course assuming your board does have two USB 2.0 ports and some have only one.  I think we tried this back at step 1, but either way you'll need to let them know that did or did not work.  

Edited by c-attack
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

https://gyazo.com/8b2d1bb52ccaa5c747c3da1a2692aa10 

https://gyazo.com/c043fa9563b8a081bf8b364881f1e4f6

This is so awkward, Have I been chatting with a bot this ENTIRE time or are my language skills non-existent? Maybe I am full on retarded and doing absolutely everything wrong here, anyway I need your help @c-attackHelp me understand this please

(short summary;- I asked for the current version HEX file for the h100i ELITE, and got the previous version of my commander core file?) Oh yeah you can also see he's copy pasting how to flash the RAM. 

This feels UNREAL

Link to comment
Share on other sites

Is the issue still the same?  Is the LCD top missing from CUE?  Or are you back to red (!)?


 

If it’s red exclamation point, the firmware flash might help — older version or not. This forces the Commander Core to do a full on assessment of its physical connection to the pump on the wide cable.

 

If it’s only the top is not detected in CUE and thus you can’t set effects or control lighting, then things usually revolve around the software.  Are you still using 4.17?    

 

Link to comment
Share on other sites

No I’m not using any other versions than the current ones, only done that on few occasions to test, but never for longer periods. The issue is still the same, LCD top not showing and the LCD showing the red [!]. Unless I uninstall or completely turn it off, atleast I get this.

5DC9E1D6-6A50-47B3-83D6-5352EBB128DD.jpeg

Link to comment
Share on other sites

3 hours ago, LucasRRR said:

No I’m not using any other versions than the current ones, only BEEN on different versions to test, but never for longer periods. The issue is still the same, LCD top not showing and the LCD showing the red [!]. Unless I uninstall or completely turn it off, atleast I get this.

5DC9E1D6-6A50-47B3-83D6-5352EBB128DD.jpeg

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...