Jump to content
Corsair Community

DDR4 2x8GB RAM doesn’t work


Recommended Posts

Hey forum!

I have recently bought the Vengeance RGB Pro 2x8 GB RAM and I built it into my pc (A2 and B2). But my pc didn’t work properly, it worked and was running, but the screen wasn’t working and also my setup didn’t light up. I removed the RAM and put my old RAM into the pc and it worked properly. I don’t know why it sonst working, because my old RAM is also from Corsair 2x8 GB DDR4 3200MHz. Maybe it’s because of my motherboard?

I have got: 

Ryzen 5 3600 AM4 3.5GHz

MSI Readon 580RX 8GB

Asus b450 f gaming

 

Thank you in advance!

Link to comment
Share on other sites

Make sure you go into the BIOS and set the RAM to default before removing your current RAM and inserting the new. That should mean disabling XMP/DOCP for most users and will return to default settings. Now put the ram in and will try to load at default values. Once that is successful you can re-enable the XMP/DOCP overclock setting. 
 

If this does not work, you’ll need to provide more detailed information like RAM model number. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...