Jump to content
Corsair Community

K70 Keyboard - randomly freaks out and opens things instead of typing


MeganElizabeth
 Share

Recommended Posts

Apologies if this already exists somewhere or if I have put this in the wrong topic area. I have had my K70 for a couple of years now, and the past few weeks it hasn't been happy. It will be fine for a while and then suddenly it will go all strange and I won't be able to type normally. Like a letter key will open control panel or settings or something. I have tried the holding esc then plugging in and letting go. I have tried pressing the reset little button on the back and plugging in and no joy. I have tried forcing a firmware update in iCUE and this hasn't helped either. Does anyone have any other suggestions? I have an old Logitech keyboard which works fine but I'd like to get my Corsair keyboard up and running again! 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...