Jump to content
Corsair Community

Icue Installation causing my PC to crash


Recommended Posts

I've been using the ICue software for about 4 years with little to no problems with it, until yesterday.

I received a notification from the software that an update was available(from v3.38 to v4.29) so i went on updating and that's when my problem started.

Started getting "Critical process died" every time i tried to update the version of the software so i just uninstalled and tried to download again directly from corsair site. Although it didn't help either, i keep getting the same error regardless of which version of ICue I try to install.

 

My system info is:

    Machine 

  •     Operating System        Microsoft Windows 10 Pro (64-bit) 
  •     Memory                32 GB
  •     Processor            AMD Ryzen 7 5800X3D 8-Core Processor           
  •     Motherboard            ASUSTeK COMPUTER INC. - PRIME B450M-A
  •     Video Cards            NVIDIA GeForce GTX 1660
  •     Monitors            XB273 GX   
  •     Hard Disk            NVMe ADATA SX8200 PNP(1 TB)
  •     Network Card            Realtek PCIe GbE Family Controller

Memory

  • General
  •     Type                DDR4
  •     Size                32768 MByte
  • Timings
  •     DRAM Frequency            1596,8 MHz
  •     FSB:DRAM            --
  •     CAS# Latency(CL)        16 clocks
  •     RAS# to CAS# Delay(tRCD)    20 clocks
  •     RAS# Precharge(tRP)        20 clocks
  •     Cycle Time(rRAS)        38 clocks
  •     Bank Cycle Time(tRC)        --
  •     Command Rate(CR)        1 clocks
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...