Jump to content
Corsair Community

"While Pressed" Macro no longer working after update to 4.29.203


Go to solution Solved by Arlyn,

Recommended Posts

I have a simple Macro that places my mouse in a certain absolute position and then left clicks, holding until I release, at which point it runs a "Release Left Click" Second Assignment. (Screenshots of the setup attached.)

This seems to be broken after the latest update. The Macro runs, but doesn't hold down left click anymore. It also doesn't seem to release afterwards, though it's hard to be sure.

Would appreciate any troubleshooting advice. Thank you!

Screenshot 2022-10-20 101859.png

Screenshot 2022-10-20 102127.png

Screenshot 2022-10-20 102114.png

Link to comment
Share on other sites

I've encountered the same issue with a similar macro (LAlt down + TAB down + TAB up + LShift down + TAB down + TAB up + LShift up) with a Second Assignment to LAlt up. (This essentially replicates ALT + TAB to switch windows, but it keeps the selector on the currently-active window as long as I hold down the macro key. I can then TAB or Shift+TAB through the list, and then the highlighted window is selected when I release the macro key.) I believe the issue is that iCUE no longer allows you to enter "unbalanced" macros, i.e. where each key press event doesn't have a corresponding key release event. In previous versions of the software, the unmatched key press event would be highlighted yellow to warn the user it was unmatched, but the application would still perform the macro as entered.

For what it's worth, I'm currently on iCUE version 4.29.203 using a K95 RGB Platinum keyboard. I don't currently have access to the computer where this macro used to work to check the iCUE version there, but I'll confirm it when I can. I read through all the iCUE patch notes and didn't see any explicit mention of a change to the way unmatched key events were handled, so assume that this functionality got hit while patching some other issue.

I can confirm that in my case, the unmatched LAlt down isn't even being registered per this keyboard event viewer: https://w3c.github.io/uievents/tools/key-event-viewer.html The sequence is entered starting from the first TAB down. When I add a LAlt up to the end of the original macro, the event viewer correctly registers the initial LAlt down event.

This seems like removal of a feature in the service of preventing users from writing buggy macros, but in my case I'm intentionally doing things "wrong" with unmatched key events and am mitigating it myself with a second macro. I'd appreciate if the interface merely warned me against doing something "wrong" rather than actively preventing me from doing it in a well-intentioned but ultimately unhelpful attempt to protect me from myself. 😉 Hopefully I'm just missing something super obvious that would allow me to write these kinds of questionable macros in the latest version.

Edited by h.h
  • Like 1
Link to comment
Share on other sites

Try running a repair install of CUE from the Windows Apps list. This often helps clean up odd issues. However, we have seen this issue once before about 12 months back and it was an unintended bug requiring a software fix. Additionally, there have been several mentions about odd macro and key assignment behavior on 4.29. I was able to clear up mine with the repair install. Hopefully it works here as well. 
 

@h.h I need to try your macro later when I’m on my setup. That’s not something I normally program. This was working on 4.28 and earlier?

Edited by c-attack
Link to comment
Share on other sites

@c-attack It turns out the last version I can confirm it worked on was 3.22.74, which I realize is pretty out of date at this point -- it must have been the version that I installed when I first got the keyboard. I tried going back a few versions from 4.29.203 last night (back to 4.28.174) but no luck, so I'm assuming this behavior change must have gone in a while ago and I'm just now noticing it because I was using a really outdated version. @Arlyn, do you happen to know what version you were using before where your macro worked as intended?

Given that it's not terribly important for me to have the macro working (it was a component of a prototype for an alternative approach to ALT + TAB that I was going to throw in front of people and get some feedback on, but I have other means of collecting the data I need), I probably won't do the exercise of binary searching through the released versions to figure out exactly where the functionality changed. I'm satisfied with accepting that this was a behavior removed in the bump to iCUE 4.x and that I shouldn't expect complete feature parity with a deprecated version, though it would of course be swell if Corsair still allowed us to write these kinds of macros.

Attached a screenshot of the old version of the app showing the macro in question just for completeness. "Macro 7" in my case is just the "release key ALT" event. 

icue_macro.PNG

  • Like 1
Link to comment
Share on other sites

  • Solution

Looks like @h.h is correct.  I just rolled back to 4.27.168 and the macro works just fine.

I also confirmed that it does not work with a clean install of 4.28.174 or later.

I did notice that in the patch notes for 4.28.174, it says "Resolved an issue where certain keyboard events would be stuck with On Press when a macro is activated." That doesn't seem like it would be directly related to this issue (I'm using "While Pressed" and a secondary macro), but maybe this was inadvertently impacted. @Corsair Raven, will this be fixed in a future update? I'm unaware of a workaround for this issue, so unless anyone can recommend an alternative way to build this macro, I'll be forced to stay on this version until the issue is addressed.

TL;DR: It seems it's not possible to build a macro in 4.28+ that ends with holding down left mouse (to be released with a secondary macro).

Thank you all!

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...