Jump to content
Corsair Community

M65 Pro RGB Mouse "malfunctioning" not recognised by windows


Recommended Posts

Hi - M65 pro mouse had been working perfectly for 2+ years but suddenly windows will not detect the usb device upon boot up stating that the device has "malfunctioned".

Ive tried it on 2 different computers (same thing) - ive tried the soft reboot method (doesn't work at all) and I've located the hard reset button under the top right weight but from what ive read on other forums it would appear i require a firmware file from Corsair to replace the corrupted one.

Is anyone able to assist in providing said file?

Thanks in advance.

Andy

Link to comment
Share on other sites

Quick update - now that I've actually tried pressing this button, it would appear that my reset button doesn't actually press anything 🤦‍♂️ so i cant even reset it by pressing the button and then plugging the mouse back in - it still says the device has malfunctioned.

Im guessing that theres no other way to reset it and im basically stuck?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...