Jump to content
Corsair Community

Virtuoso XT - Bluetooth not working, no LED

Recommended Posts

I hold the MFB and I never see the blue light, or anything different show up. I've tried to force update the firmware to no avail. Flipping the switch does nothing for when holding the button. I dont seem to see any other reports of a problem like this, usually with a red blinking led, but I have no indication at all.

Any help is appreciated, thanks!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

Hi Mario,

Did you make sure to hold the bluetooth button until the light flashes red and blue?

If the issue continues can you reset the unit.

To soft reset your headset make sure your mic is plugged in:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset to wired mode and then back to wireless mode.

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 months later...

I am just now having this same issue. My headset suddenly refuses to turn on and connect to the dongle after I set it down, but it connects to my PC via the cord just fine. It won't let me do the mic reset because it won't turn on via wireless. Tried doing the reset wired but that didn't help, also tried forcing an update, that didn't help either.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...