Jump to content
Corsair Community

Corsair Ironclaw RGB Wireless keeps dropping bindings in wireless mode. Can only use mouse if it's plugged into the power cord


Recommended Posts

Like the title states, while using the mouse in wireless 2.4ghz mode, the mouse will work for a bit and then drop all assigned key functions. Only mouse buttons that work, are left and right mouse buttons. I have to plug the mouse back into the power cord to get the mouse to work again.

iCUE v.4.25.155

Ironclaw rgb Wireless v.5.0.130

Slipstream wireless usb receiver v.5.66.126, plugged into usb port on pc. At first I had this plugged into my K95 usb slot, but then moved it to the PC. I've tried all usb ports on my pc. All with the same result.

icue and device version.PNG

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...