Jump to content
Corsair Community

iCue does not detect my Corsair Dominator Platinum DDR4 3200mhz when booting the computer


Recommended Posts

It used to be random when icue would not detect my dominator platinum ddr memory, now it happens almost all the time. Before I dive further, my specs:

  1. Intel Core i7 12700k
  2. Asus TUF Gaming Z690 Prime MB
  3. 32GB Dominator Platinum DDR4 3200mhz
  4. H150i elite Liquid Cooler
  5. Radeon RX 580
  6. Corsair 4000x Case
  7. Windows 11 pro

I searched the web but did not come to a proper solution to this issue. If I start my computer after it has been off for a while, the icue software fails to detect my RAM. However, if I restart the icue service or restart the computer, it can detect the RAM again.

If I shut down the computer and start again a minute after, it can detect the RAM. If I shutdown and start the computer after an hour or more for example, it has a chance not detecting the RAM when booting to windows 11.

I tried clean installing icue software and uninstalling asus armory software, it did not help. I also tried enabling and disabling SPD Write, it does not help.

It is not the end of the world as simply restarting the icue software fixes this, however it should be the case and can be annoying. Here is link to my logs

https://1drv.ms/u/s!AhpXdbHGHjIuh4hKLxLN-nIc_LV5Ag?e=rWSX3z

 

Link to comment
Share on other sites

Z690 motherboards need SPD write enabled to communicate with the RAM.  Asus does this in a strange fashion by using a double negative to enable it.  You need to set it to "FALSE" whether you have DDR5 or DDR4 RAM.  This is a motherboard safety feature and was present on the first generation of DD4 boards as well.

https://help.corsair.com/hc/en-us/articles/5718039999117-How-to-Enable-SPD-Write-on-your-ASUS-Z690-motherboard

 

Other than that, the intermittent contact is not a commonly reported issue.  If you intend to use the Asus plugin for CUE to control your motherboard RGB, you need Armory Crate installed.  A conflict here most of often causes loss of lighting control, not non-detected.  Make the SPD setting is set to False in the BIOS and boot up.  Go into the CUE settings and turn on debug logging.  If this continues to be a persistent issue, contact Corsair Support and manually export the logs after one of these failed detections on boot.  

Link to comment
Share on other sites

27 minutes ago, rock1m1 said:

doesn't make a difference for me.

It does make a difference.  If you leave SPD write disabled you have zero chance of success.  Set it to false and leave it.  

Link to comment
Share on other sites

I tried, after shutting down the computer and starting it after a while, icue doesn't detect my RAM. Restarting the icue software fixes it. I don't have any background apps apart from icue, one drive.

Link to comment
Share on other sites

There’s nothing obvious in your hardware or setup, other than using DDR4 on DDR5 board. Some are dual capable. Some force you to choose. I can’t find anything definitive on the Asus site, other than a QVL list that starts at 4400. It’s possible there is something about the board physical setup that interferes with detection, but that’s a bit speculative. I would contact Corsair Support. 
 

Most users who encounter this have other (non-Asus) RGB programs that try and grab control during the load sequence. One potential workaround is to set CUE not to start with Windows, then manually launch it after boot. In theory that should side step a boot sequence issue with some other program. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...