Jump to content
Corsair Community

I can't configure LCD screen H150I ELITE in its latest version of icue


Recommended Posts

Hello,

First of all, I want to apologize for my language, but I don't speak English.

To start, I want to say that I have built a new PC using an "Asus ROG STRIX B660-A GAMING WIFI D4" motherboard on a 7000X chassis to which I have added an "H150i elite LCD" cooling.

The way to connect it is as follows:

To the motherboard, the H150i LCD package splitter. To the first connector of this, the commander core TX of the chassis and to the male of the commander core the pump of the H150i LCD.
To the other dual connector I have connected the refrigeration commander core.

I have tried to connect my devices with various alternatives, but when I connect the PC to the power, the warning triangle appears on the LCD screen.

The motherboard has a single 9-pin and one 5-pin USB 2.0 connector.

With the hardware connected in this way, I see that everything works correctly, except that the LCD screen configuration section does not appear in icue.

ConfigEliteLCD.thumb.png.7b08850bff143fb2786b8440012f7b72.png

I am using the most recent firmware and app versions to date, 4.25.155.
 

versions.png.d4ddf93315edc4b8100212d13e0f3fb5.png

Does anyone know the solution so that I can configure the LCD screen?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...