Jump to content
Corsair Community

Corsair Virtuoso not working in wireless mode anymore.


Recommended Posts

Yesterday my Virtuoso worked well in wireless mode and it suddnely did not work anyore since today.

The dongle kept flashing red, so as the Virtuoso when in wireless mode.

Icue cannot even recognize my dongle, nor show the version of the current firmware.

I pressed check on update, and pressed got it, the wireless receiver thing was gone. couldnt find in anywhere again.

I am not sure what happened and please show me how to make it work again...

Screenshot (37).png

Screenshot (40).png

Screenshot (41).png

Link to comment
Share on other sites

  • Corsair Employees

Hey CSs!

Sorry to hear you're experiencing an issue with your VIRTUOSO's headset. Can you try doing a soft reset on your headset to see if it will address your issue? 

To soft reset your headset:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

Link to comment
Share on other sites

1 hour ago, Corsair Crimson said:

Hey CSs!

Sorry to hear you're experiencing an issue with your VIRTUOSO's headset. Can you try doing a soft reset on your headset to see if it will address your issue? 

To soft reset your headset:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

Thank you for your reply. I dont think that is the problem of the headset itself but the dongle. The headset works perfectly with USB connection.

However I still tried your method but it seems it didnt change anything abot the flashing red light of the dongle.

Link to comment
Share on other sites

  • Corsair Employees
59 minutes ago, CSs said:

Thank you for your reply. I dont think that is the problem of the headset itself but the dongle. The headset works perfectly with USB connection.

However I still tried your method but it seems it didnt change anything abot the flashing red light of the dongle.

Hey there, sorry to hear that, go ahead contact our support team by opening a ticket at https://help.corsair.com so our support team can assist you further with the next step.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...