Jump to content
Corsair Community

iCUE crashes on launch


GregTheTerran
 Share

Recommended Posts

Hello,

I just bought an Asus Z590 mobo, RTX 3060, intel i7 11thgen, and corsair venegence pro 16gb DDR4.

I was able to get iCUE to launch correctly in my initial install of Windows 10 for one day. I made no hardware changes besides moving the PC to the otherside of the room, and then I booted it back up. iCUE crashes on every launch. 

I have taken many troubleshooting steps, most recently I did a completely fresh install of Windows (now Windows 11 pro). The very first thing I did was install iCUE. It still crashes on launch. 

Any idea what might be happening here?

Thanks,

 

Link to comment
Share on other sites

Oh wow! No I did make a hardware change, I just forgot about it. 

I switched to a Corsair K55 RGB keyboard. This is unmistakably causing the iCUE program to crash. If i unplug that keyboard and use a different one, it works fine. This keyboard also cause the RAM to no longer integrate with Armoury Crate.

Is there anyway to get around this?

Link to comment
Share on other sites

I fixed it. Steps to fix, and yes, they suck. 

  1. Uninstall iCue. Remove any trace of it. Appdata folder and registry entries. 
  2. Install CORSAIR iCUE v3.38.88 (For Legacy Devices) from here. https://www.corsair.com/us/en/downloads
  3. Follow the directions here from this post. https://forum.corsair.com/forums/topic/149613-corsair-k55-not-connecting-to-icue/?do=findComment&comment=928857 
  4. Update the firmware for the keyboard. 
  5. Keep using the legacy version if you like. Or uninstall it and install the latest version. Both worked for me. 

Take note that my K55 was purchased in 2017. I had never updated the firmware. So your milage may vary. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...