Jump to content
Corsair Community

Trouble Shoot my AX 1200i


Recommended Posts

I think my Ax 1200i is dead. I tried reseting it and no lights. Then I turn on the computer and All I hear is a click near the power supply. Nothing else happens. NO boot up. 

I have a Asrock z87 11/a/c board Intel Core i7-4770K Quad-Core Desktop Processor 3.5 GHZ 8 MB Cache BX80646I74770K. Trying to replace my EVGA RTX 750ti and with a RTX 3060TI when this happened. After putting the new board in, and it tried to boot for 3 minutes then died (Didn't Boot) I put the old 750ti back in to see if it may have been the new 3060ti and the computer won't boot just the click noise. I have a hydo series H100 on the CPU.  I've already spent $600 on the card thinking it was the 750ti that was the problem. If I have to replace the power supply, I might as well replace the board, CPU & RAM and use everything else for the new computer. 

Reading that this power supply is a workhorse... Well, Not in this computer. Its completely stock. I just overbuy & try to future proof. Can anyone help me trouble shoot the power supply if the computer won't turn on in the first place?

 

Thanks in advance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...