Jump to content
Corsair Community

Slipstream dongle not working with MM700 RGB


ArbalestNL
 Share

Recommended Posts

Hello

I recently purchased a Corsair Dark Core RGB Pro SE and swapped the wireless dongle of my old mouse (older version of Dark Core RGB, which always worked without problems in the MM700 hub) with the new Slipstream dongle.

Updated iCUE to version 4.24.193 and the mouse firmware to version 5.0.41. The MM700 firmware is version 1.0.5.

As the topic title says, it doesn't work.

When I plug the dongle into the MM700 I hear the Windows 11 usb connection sound, but the dongle doesn't show up in iCUE.

When I plug the dongle directly into the front USB of my PC it DOES work.

The MM700 RGB is advertised (on this very forum by Corsair) to support the Slipstream dongle, but appearently it doesn't. Will this be fixed in a future firmware update?

Edited by ArbalestNL
Link to comment
Share on other sites

I checked it with my "Dark Core RGB Pro SE" and it worked fine on my MM700 hub. Hopefully, someone from Corsair can help you out with it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...