Jump to content
Corsair Community

LCD AIO displays red triangle and won’t show up on iCUE software


Recommended Posts

This issue started happening to me about two weeks ago. I fire up my computer and was instantly greeted with the red triangle. Then all of a sudden my computer would shut off. Went to turn it in on and everything was fine. It would do this everytime I go to turn on my computer. I also found out that my cpu temps would skyrocket to about 90 plus Celsius causing my computer to turn off. I went to reseat the cooler when the computer was on and at first it worked. Turned it back off and on and the triangle came on again. It was a rinse and repeat until I figured it probably was a dead pump. Went to get a new pump and everything worked fine. But now I’m having an issue to where the lcd won’t show up in icue 4. Did a fresh new install of icue 4 but nothing. The commander pro showed up and did a firmware update but the lcd aio still doesn’t show up. I contacted Corsair and waiting for them to get back at me. Do you think it’s the lcd cooler itself? 

Link to comment
Share on other sites

On 6/18/2022 at 5:56 AM, Sabasd94 said:

But now I’m having an issue to where the lcd won’t show up in icue 4

There are some outstanding issues with this product. It seems like you had a real pump failure on your first.  That is not common, but there are other users who experience the ‘false alarm pump fail’ where the software thinks the pump has failed.
 

Your LCD detection problem is reported by other users and there is a long discussion thread (below). The basic first step is to shutdown the system, flip the PSU off, unplug the special wide connector for the pump on the Commander Core, then reconnect making sure it’s fully inserted and white mark lined up. Now flip the PSU back on and power up. This should force the Com Core and LCD to reassess their status. Fingers crossed. 
 

If that does not work, then you are into the more complex usb connection management. Try to split the lcd hub and Com Core to their own usb 2 port or more likely powered usb hub. This can be motherboard dependent and some users find relief by routing to usb 3 ports using adapters. 
 

https://forum.corsair.com/forums/topic/176547-elite-lcd-megathread/#comments

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...