Jump to content
Corsair Community

HS70 PRO Wireless Sound Not Working


Recommended Posts

I've been using these headphones for a few months and had no problems until today when the sound stopped working completely. I can still hear the beeps when I turn the headphone on and off along with the microphone working completely fine, but voice commands don't work. Any other audio device I use also seems to work too and in the sound settings the bar still moves to indicate when noise is coming through, but I hear nothing with these specific headphones. In addition, if I unplug the dongle and then plug it back in and then turn on the headphones, I can sometimes hear the voice commands and any other sound for a brief moment before it stops working again. I've tried restarting my computer and soft resetting the headphones but that hasn't worked. I haven't seen anyone else with a similar problem online which matches mine, does anyone know what I might be able to do to fix it?

Link to comment
Share on other sites

  • Corsair Employees

HI Kubrow,

Attempt to repair the iCUE software:

Control Panel

Programs and Features

Right Click the iCUE software

Select Repair

Restart computer

 

Have you updated the firmware of the device? We would suggest that next for the unit.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...