Jump to content
Corsair Community

iCue Stopped detecting GPU (Strix 3090) after latest Nvidia Geforce Driver Release 516.40


Recommended Posts

I have 2 builds each with a Strix 3090. The latest version of the driver caused the GPU to STOP being detected in iCue. I tested on both machines. It is the GeForce Driver doing this. if anyone knows how I can manually re-enable GPU detection would be highly appreciated. I will roll back the driver for now. Figured I would post this as I confirmed it 100%. I left a post over on the geforce support forums as well.

Link to comment
Share on other sites

Make sure you restart your the PC (or CUE and it’s services) after a gpu driver update. CUE gets its info from that driver, so when the old one is removed it loses its place until the next restart. 

Link to comment
Share on other sites

Partially solved
Rolled back to Nvidia driver 512.95 and all is working fine
  • Thanks 1
Link to comment
Share on other sites

Same problem here. i think i will roll back to 512.95 driver

Link to comment
Share on other sites

  • Corsair Employees
On 6/15/2022 at 12:32 PM, Theos25 said:

I have 2 builds each with a Strix 3090. The latest version of the driver caused the GPU to STOP being detected in iCue. I tested on both machines. It is the GeForce Driver doing this. if anyone knows how I can manually re-enable GPU detection would be highly appreciated. I will roll back the driver for now. Figured I would post this as I confirmed it 100%. I left a post over on the geforce support forums as well.

As of right now, iCUE GPU detection on Nvidia's latest driver is a known issue and would require a rollback to driver version 512.95

  • Thanks 1
Link to comment
Share on other sites

Same problem here with Rog Strix 3080 OC.

Link to comment
Share on other sites

Same issue with not showing in iCUE on a Rog Strix 2080Ti with the new 516.40 NVidia driver

Link to comment
Share on other sites

The temporally quick fix: After windows boot and if your iCUE auto startup, exit iCUE and wait for a while and turn on iCUE. After a while it will detect your Nvidia GPU iCUE. But I tested the system came with Asus Armoury Crate. Hope it help. 

Link to comment
Share on other sites

Posted (edited)
On 6/18/2022 at 10:15 AM, ahfoo said:

The temporally quick fix: After windows boot and if your iCUE auto startup, exit iCUE and wait for a while and turn on iCUE. After a while it will detect your Nvidia GPU iCUE. But I tested the system came with Asus Armoury Crate. Hope it help. 

This doesn't work. There is no quick fix with the new nvidia drivers, only way that works on my 2 builds is to rollback to a previous version.

Edited by Theos25
Link to comment
Share on other sites

19 hours ago, Theos25 said:

This doesn't work. There is no quick fix with the new nvidia drivers, only way that works on my 2 builds is to rollback to a previous version.

I am sure what went wrong, but I managed to do it. That is strange,

Link to comment
Share on other sites

Same issue with an AMD Vega 64. Their latest driver also broke the monitoring in iCue.

Link to comment
Share on other sites

New version of geforce drivers (released june 28 - 516.59) still have the same problem. 

Link to comment
Share on other sites

On 6/29/2022 at 9:56 AM, Theos25 said:

New version of geforce drivers (released june 28 - 516.59) still have the same problem. 

I can confirm this as well.

Only solution right now is to roll back to driver version 512.95 until a proper fix is released.

Link to comment
Share on other sites

On 7/6/2022 at 3:43 PM, Corsair Raven said:

As stated before, rolling back the driver to 512.95 is the current workaround.

Do you have a guide to roll back the drivers on ASUS 3070 GPU? And is is safe to roll them back? I'm facing the same issues as noted above.

 

Thanks in advance. 

Link to comment
Share on other sites

2 hours ago, kparr_90 said:

Do you have a guide to roll back the drivers on ASUS 3070 GPU? And is is safe to roll them back? I'm facing the same issues as noted above.

 

Thanks in advance. 

For me, All I did was just download 512.95 drivers and I think they give you an option for a 'clean install'. Otherwise, you can uninstall the current drivers from device manager or remove "Nvidia graphic drivers" from add/remove programs. 

You can use Nvidia advance search here;

http://www.nvidia.com/Download/Find.aspx?lang=en-us

Under search preferences, look for 'Windows Driver Type:" switch it from Standard to DCH.

It should then give you a list of drivers, look for 'GeForce Game Ready Driver WHQL 512.95 May 24, 2022.  You should be able to click the link and leads you to the download. From there you can install it and have the option to do a 'clean install' checkbox. It will remove the current drivers and install 512.95

If your uncomfortable with installing drivers, then as a precaution, wait for the next update from Nivida that fixes the issus. So far, they haven't fixed it, so I'm staying on 512.95 until there is confirmation that it has been fixed.

Edited by SpabalinasDesign
Link to comment
Share on other sites

i personally just installed 512.95 and it removed the newer driver automatically during installation.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

There is another workaround till this get's resolve that allows you to use the latest driver with ICUE.   Set the Run as Admin option for ICUE.EXE.  Icue will no long autorun at boot even if enabled but you can then run it and it will detect your NVidia GPU using the latest driver.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...