Jump to content
Corsair Community

H150i ELITE LCD Display Liquid CPU Cooler randomly disappearing from iCUE


Recommended Posts

Hi Everyone,

 

I’ve been having problems with my H150i ELITE LCD Display Liquid CPU Cooler. For some reason the device will work for a few minutes (or even up to 6+ hours) then the device will be removed from my iCUE program. But before it crashes it makes a USB connecting/disconnecting sound multiple times. I notice after it does crash, the USB connecting/disconnecting sound will not randomly make that noise again. 

 

What’s weird about this is that the device still works however the gif I use on the LCD screen freezes, RGB lighting will go back to the hardware lighting (Rainbow) and I can not make any changes to the H150 cooler due to the fact that the device gets removed from the iCUE software.  

 

The software I am using is v. 4.24.193

 

As I am writing this, the firmware is version 2.20.219 and the LCD Screen Firmware is version 1.1.7.7

 

I do not use the fans that came with the product, instead I use the Corsair LL Series 120mm Fan with RGB lighting. (I use 6 of these fans and they are connected to the Corsair iCUE commander core which came with the product)

 

Honestly, I think this might be an actual software issue instead of physical “hardware” problems. I notice on the corsair website that “H150i ELITE LCD Display Liquid CPU Cooler” is not listed under compatible devices with iCUE as I write this post. 

https://help.corsair.com/hc/en-us/articles/360058142592-iCUE-4-compatibility-list

 

Does anyone know how to fix this? If know please let me know, Like I said before I believe that this just might be a iCUE software issue which I can't necessarily control. 

 

Here are my PC Specs:

  • 11th Gen Intel Core i9-11900k 3.50GHz, 8 Core - 16 Thread

 

  • (64GB RAM) Corsair Vengeance RGB PRO 32GB(2PK x 16GB) 3600MHz DDR4 C18 DIMM Desktop Memory 

 

  • Corsair Power Supply 850W

 

  • ASUS ROG STRIX Z590-E Intel Motherboard  LGA 1200 USB 3.2 Intel Motherboard

 

  • CORSAIR - MP600 CORE 2TB PCIe Gen 4 x4 NVMe M.2 Internal Solid State Drive with Heatsink






 

Here’s what I’ve tried:

 

  • I plugged the cooler usb cable directly into the motherboard (both usb slots did not work on my motherboard) . I also do not use any of the y splitters that came with it.

 

  • My power plan is on “High Performance” and the USB selective suspend setting is on “Disabled 

 

  • I removed armoury crate and other asus programs from my pc but it still keeps crashing.

 

  • I did a complete power shut off reset, powered off, unplugged for a whole day and it still crashes.  

 

  • I have repaired/reinstalled iCUE software like over 20 times. (4.24 and even 4.22 to see if downgrading would work.) 

 

  • Most of my USB ports have the option “Allow the computer to turn off this device to save power” unchecked. 




 

Irrelevant things to know (maybe could be the problem?):

 

  • I have a standard default PS5 controller that I have Overclocked to the max. The cable I use for it is a Type C to Type C apple charging cord. 

 

  • The images/gif that I use are on my main C drive, no images are used in a different storage device. 

 

  • The games I play (WarZone, ColdWar, and Fortnite) are all on low graphics settings.

 

  • My hardware lighting channel is on rainbow but I use a profile with a secondary lighting option known as “Watercolor Spectrum” 

 

  • I have only 2 profiles in the iCUE software

IMG_4110.jpg

IMG_4111.jpg

IMG_4112.jpg

Before iCUE Crash.png

Link to comment
Share on other sites

Device detection is a USB issue. Most of the time it is physical (voltage) rather than software conflict and I don’t see any inherent problems on the software side. Be careful of other programs that poll Corsair internal devices, like HWinfo or AIDA. You must disable monitoring of the AIO or PSU. 
 

However, most likely you are going to be like the users in the thread below. There isn’t a surefire solution for everyone and it seems to vary by motherboard. Z590 does not come up as often and the relatively long periods between drops suggests a voltage output dip on the board vs inadequate voltage from the start (never detected). That suggests trying a powered usb hub to stabilize the usb voltage output might be your best bet. However, looking at your device list I count 3 internal usb connections already which makes me wonder if you already have one (LCD top, Commander Core, Lighting Node Core). Plan B would be a usb 3->2 adapter which has worked well for those on Z690. 
 

https://forum.corsair.com/forums/topic/176547-elite-lcd-megathread/#comments

 

 

When the AIO “drops out”, it’s loses its ability to talk to the software. Thus the lighting on the affected device(s) drops to its hardware lighting state saved to the controller. It seems like perhaps the LCD top is dropping out (GIF freeze and drops from cue) but the Commander Core and fans connected are still present and running software lighting?  Or both drop out?  That may indicate which usb path is the problem, but the LCD top is complicated and entangled with the Commander Core for data and power. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...