Jump to content
Corsair Community

my XD5 pump isnt working, need help


Recommended Posts

Hi there

 

i have a xd5 pump/res with the gpu and cpu cooling in the loop too also corsair branded parts, power is on all of them but theres no flow of coolant around the loop and theres no humm of the pump, unsure how i activate it in icue if thats even possible or if the part is just faulty

Link to comment
Share on other sites

everything is connected for the pump? don't forget the molex, the pump isn't powered from the PWM cable.

How is it controlled? commander pro/coreXT using HydroX assistant? another controller?

Link to comment
Share on other sites

2 hours ago, LeDoyen said:

everything is connected for the pump? don't forget the molex, the pump isn't powered from the PWM cable.

How is it controlled? commander pro/coreXT using HydroX assistant? another controller?

its via commander pro i believe as it recognises it for the rbg, i didnt wire it up it was done by an engineer as a custom order, i wouldnt know what wire im looking for honestly i dont have a hydro x assistant popup though?

Link to comment
Share on other sites

The RGB cable is independent from pump function as passed along that cable to the LED 1/2 port on the Commander Pro. The CommanderPro does not auto recognize, so someone told it what’s on the other end in Lighting Setup. That also means someone likely dismissed the Hydro X assistant, but it’s not needed right now anyway. 
 

Coming out of the base of the XD5 will be a thicker sleeved cable that leads to a molex connector on a special molex PSU cable. That is pump power. Kind of rare for something to be completely dead of of the box and even stranger if it was built by someone else who would have needed it functional to fill it up.  Check for the molex and while doing that follow the PWM fan connector (2 wire) back from the pump to where it’s connected (Commander Pro or MB). The next time you power up it will run at maximum to eliminate and control issues. 
 

***Don’t ever connect the PWM/tachometer cable from the XD5 to a live controller. It tends to react badly, unlike most fans. When this is sorted and you’re ready to connect it back to regain control, shut the system down first, then reconnect. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...