Jump to content
Corsair Community

Corsair Void Headset stopped working (dongle heating up a lot)


Recommended Posts

Hi there,
My corsair void wireless suddenly stopped working: 
1) I can charge the headset and I get sound feedback when I pull up/down the microphone, however no sound from PC and the headset is not recognized by the system nor by iCue.
2) I tried to update iCue, uinstall and reinstall. Still nothing.
3) I tried on another PC and still the same issue. The dongle heats up pretty bad on every machine I try it.

Any idea of this can be fixed at all or are my headsets gone for good?
/Alejandro.

Link to comment
Share on other sites

To add more infor to this issue. 

1) I Have Corsair Void Elite 7.1 bought exactly a year ago
2) The problem started with no reason and the headsets were working well until now.
3) I tried to press the mini button on the dongle and still nothing.

Link to comment
Share on other sites

  • Corsair Employees

Hello there! Sorry to hear about that, I can see you've done a good amount of troubleshooting already, but I'd recommend trying a reset:


1. Make sure your headset is powered off.
2. Hold the Mute button on the headset down for about 15 seconds.
3. Hold down the power button until the headset turns on.
4. Test your headset and see if the issue is resolved.

If you're still having issues, I would recommend you reach out to our support team by opening a ticket at: http://help.corsair.com so they can assist you further.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...