Jump to content
Corsair Community

corsair icue H150i elite CAPELLIX header for pump is broke


Recommended Posts

Hi there 

 

I just get my new corsair icue H150i elite CAPELLIX i installed anything like Corsair manual said, any pressure on thé chip is good and  now i get constant issue with heat bc thé pump doesnt work, it worked for 15 minutes and now yea i guess thé header is dead and i did anything, so pls help me!!

Link to comment
Share on other sites

  • 3 weeks later...
On 6/5/2022 at 3:26 AM, Technobeard said:

@Louisbaecke510 Please create a support ticket at https://help.corsair.com.

i did, but not much help come from it, it's just frustrating that a 200€ AIO is not working, after hours of searching i found some info to revocer some things but it's still broke let me explain, 

 

 

First boot of it the RGB etc worked, but pump don't work very well ( PSU whas low so not enough power). i orderd a PSU from corsair, the rm850 after that my pump worked very well, but you can guess it, no rgb at all, just the whole AIO + front fans are flashing red but the pump works fine so i whas already happy that worked. after a lot of trying me and some friends thinking that the motherboard is the blame so i changed it to a Asus rog strix Z590-e gaming wifi, but it still dont work so i tried some reset things that people are saying on the forum and it worked 1 time my rgb but after i shut down my pc and start it again it flash it again. if i rest the pump my commander core works and find on the icue program, after i shutdown and start it again he don't find my commander core , only the pump as ''unknow device'' and i cant change things if this happens, see pics below to see my problems.

 

 

IMG20220613091426.jpg

IMG20220617150817.jpg

IMG20220618111948.jpg

IMG20220620090449.jpg

IMG20220620090223.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...