Jump to content
Corsair Community

Corsair K100 RBG Optical keyboard sometimes not detected on wake post update to Windows 11


Recommended Posts

Posted (edited)

OK, so after updating to Windows 11....


Sometimes the keyboard doesn't light up and respond after wake.
Not even a shutdown solves this.
The keyboard has to be replugged.
It seems like the sleep might "crash" the K100 or something and it requires a "reset".

I have the latest iCue, firmware, Motherboard Bios.

Any clues?  Thanks!

Edited by rasmasyean
Link to comment
Share on other sites

  • Corsair Employees

Thats a USB port enumeration issue. Make sure your chipset and USB drivers are fully updated, and that your BIOS is fully updated. Also check and make sure that Selective USB Suspend is not set to Enabled in the power management settings for Windows. 

Link to comment
Share on other sites

Didn't work.  Also, updating stuff seemed to have made it worse.  Now I have to do a power cycle to get it to work when it bombs out.

Also, I don't think it has anything to do with sleep, at least not anymore.  It appears to randomly occur on boot up from power cycle even.  And when it does occur, replugging makes the chime but the keyboard doesn't light up or respond...thus requiring another power cycle.

For the record, this is the motherboard:
ASUS PRIME Z490-A LGA 1200 Intel Z490 SATA 6Gb/s ATX Intel Motherboard
https://www.newegg.com/p/N82E16813119289?Item=N82E16813119289

Link to comment
Share on other sites

Posted (edited)

Something new I found.  When I unplug the "USB Passthrough" of the K100, replugging the Keyboard USB seems to make it detect instead of requiring a power cycle.  Not sure how that works as I thought the USB Passthrough was just wires.  Does it run through the keyboard electronics for some reason?

Edited by rasmasyean
Link to comment
Share on other sites

Here's a weird effect and I'm not sure if it's just coincidence.

I enabled XMP on the motherboard and it significantly improved the detection rate.  It's not 100%, but very noticeable.

Prior to "Windows 11 update", I had flashed the motherboard BIOS to the new version so it reset defaults on the motherboard. (i.e. XMP disabled)  Now that I got around to it, I enabled XMP again and it seems it changed the keyboard detection behavior.

Any explanation for this?  Maybe the keyboard is very sensitive to "speed of detection"?

Thanks?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...