Jump to content
Corsair Community

iCue stopped showing my GPU in the dashboard


Recommended Posts

It stopped showing my GPU in the dashboard. I tried clean installing the icue, it did not work. Using icue version: 4.24.193

My system:

Intel 12700k

32GB Dominator RAM

H150i liquid cooling

4000x Corsair case

RX 580

Link to comment
Share on other sites

I'm going through this exact same problem and no one has helped me with anything except through email and the suggestion was fully uninstall iCUE and reinstall which did absolutely nothing. I'm running 3.38.88 and my GPU temp sensor has disappeared completely and I use it for temp monitoring to change the speed and color of my exhaust fans.

 

You can see my full thread here: 

 

Link to comment
Share on other sites

  • Corsair Employees
2 hours ago, rock1m1 said:

It stopped showing my GPU in the dashboard. I tried clean installing the icue, it did not work. Using icue version: 4.24.193

My system:

Intel 12700k

32GB Dominator RAM

H150i liquid cooling

4000x Corsair case

RX 580

Have you made sure you are running the latest motherboard BIOS and that you are not also attempting to run other hardware monitoring software at the same time as iCUE?

 

34 minutes ago, Stark1981 said:

I'm going through this exact same problem and no one has helped me with anything except through email and the suggestion was fully uninstall iCUE and reinstall which did absolutely nothing. I'm running 3.38.88 and my GPU temp sensor has disappeared completely and I use it for temp monitoring to change the speed and color of my exhaust fans.

 

You can see my full thread here: 

 

The iCUE 3 software has not been updated in quite some time as it is no longer actively developed and only intended for legacy device support. Did you recently update your BIOS or other software pertaining to your motherboard or GPU?

Link to comment
Share on other sites

54 minutes ago, Corsair Notepad said:

Have you made sure you are running the latest motherboard BIOS and that you are not also attempting to run other hardware monitoring software at the same time as iCUE?

 

The iCUE 3 software has not been updated in quite some time as it is no longer actively developed and only intended for legacy device support. Did you recently update your BIOS or other software pertaining to your motherboard or GPU?

No... nothing has changed except a new windows install from Windows 11 back to Windows 10... I have even tried iCUE 4 and it doesn't show my gpu either. I haven't had any issues with 3.38.88 at all but all of a sudden no gpu.

Link to comment
Share on other sites

2 hours ago, Corsair Notepad said:

Have you made sure you are running the latest motherboard BIOS and that you are not also attempting to run other hardware monitoring software at the same time as iCUE?

 

The iCUE 3 software has not been updated in quite some time as it is no longer actively developed and only intended for legacy device support. Did you recently update your BIOS or other software pertaining to your motherboard or GPU?

I have the latest BIOS as of March 2022. It was fine prior to this update.

Link to comment
Share on other sites

I face exactly the same issue, no changes at all - after a regular system reboot my Suprim 3090 doesn't show up anymore.
Nope, no driver changed, no windows update, but a little bit before, ICue has changed and introduced quite a magnitude of bugs for me 😞

Link to comment
Share on other sites

  • Corsair Employees
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...