Jump to content
Corsair Community

2nd H100i RGB Pro XT Fan Noise, replacement?


Recommended Posts

I have been using Corsair products for a number of years, just replaced a 7 year old H105 that is still working great. I recently bought a H100i RGB Pro XT and some of the new Vengeance RS memory.

This is the 2nd H110i I have ordered in the same number of months with the first one having to be RMA'd due to pump failure issues. It was purchased from Newegg Canada which for me is across country. The turn around time from when I sent the cooler out to when I received a new one was almost a month.

Now with this unit from RMA, I seem to be having a extremely annoying constant hum coming from one of the fans which can be heard here I know it is the one fan because if I switch it to zero RPM mode, the sound disappears.

My question is there any way I could be sent a replacement fan without having to RMA the entire cooler again? Having to install, then remove the first H100i, re-install the H105, wait a month and having to do it all over again has really been a pain in the butt.

Link to comment
Share on other sites

  • Corsair Employees

Based on that video there is nothing abnormal with the the cooler or its fans.

Link to comment
Share on other sites

31 minutes ago, Corsair Notepad said:

Based on that video there is nothing abnormal with the the cooler or its fans.

Thanks for the reply. It is kind of hard to catch it on video as my phone is in a Lifeproof case, but I tried to get another video of it here It starts zero rpm mode around the :20 second mark and back to balanced at around 1:20. The other fan does not produce this sound at all.

Link to comment
Share on other sites

There is without a doubt an issue with this particular fan. I can feel some pretty decent vibration consistent with the sound it makes when I put my hand on the side panel of my PC. It is also the first thing I hear when I walk into the room. The other fan on the rad does not produce anything close to this same sound. I have taken another video here with the fan in question being put to Zero RPM mode at about :30 seconds and back to Balanced mode at about 1:25.

Link to comment
Share on other sites

Typically if it is just a fan, that is all Corsair would require to be sent in.  The tricky part is in countries where the retailer acts as the RMA agent.  I do think you should start a support ticket with Corsair for this.  The fan on the H100i XT is most similar to that below, which is sold in a two pack.  However, I also found a listing for a single one from the "Corsair store".  Factoring in shipping costs, this could be a better solution for you.

https://www.amazon.ca/Corsair-Premium-Magnetic-Levitation-2-Pack/dp/B01G5I6MRK

https://www.amazon.ca/Corsair-ML120-Magnetic-Levitation-CO-9050049-WW/dp/B08DL4RF71/ref=sr_1_11?crid=1V8ZGA99RQNTC&keywords=Corsair+ML+Pro&qid=1653860743&s=electronics&sprefix=corsair+ml+pro%2Celectronics%2C201&sr=1-11

Link to comment
Share on other sites

35 minutes ago, c-attack said:

Typically if it is just a fan, that is all Corsair would require to be sent in.  The tricky part is in countries where the retailer acts as the RMA agent.  I do think you should start a support ticket with Corsair for this.  The fan on the H100i XT is most similar to that below, which is sold in a two pack.  However, I also found a listing for a single one from the "Corsair store".  Factoring in shipping costs, this could be a better solution for you.

https://www.amazon.ca/Corsair-Premium-Magnetic-Levitation-2-Pack/dp/B01G5I6MRK

https://www.amazon.ca/Corsair-ML120-Magnetic-Levitation-CO-9050049-WW/dp/B08DL4RF71/ref=sr_1_11?crid=1V8ZGA99RQNTC&keywords=Corsair+ML+Pro&qid=1653860743&s=electronics&sprefix=corsair+ml+pro%2Celectronics%2C201&sr=1-11

I have used the process of elimination to confirm there is an issue with this fan no doubt, the videos speak for themselves. I'm just glad it isn't a pump issue like the 1st cooler.

The fans you linked are the same ones that came with the cooler, I was eyeing the 2-pack when I was thinking about doing a push-pull setup with the fans that came with the cooler.

This whole thing has kinda left a bad taste in my mouth. My H105 lasted me 7 years without a single issue, it is why I decided to go with another Corsair AIO, but now having issues with 2 different H100i's in the same number of months is kinda ridiculous.

I will open a ticket and see what they say, but if I have to shell out any more money to fix this fan issue, I will most likely be buying fans from a different brand and will no longer be buying or recommending any Corsair products going forward.

Link to comment
Share on other sites

It has been a week since I made a ticket and the only response back was 5 days ago that I was being transferred to technical support for some reason.

I have shown the videos to multiple people and they all agree there is 100% an issue with this particular fan. I don't know how you can say there isn't@Corsair Notepad

Having to shell out more of my money to fix what is an apparent QC issue on Corsair's part is unacceptable IMO.

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...