Jump to content
Corsair Community

I300 Updates Plz!


Recommended Posts

Dear Corsair,

After 6 months of waiting for a single update for our $5000 i300 systems and now your new a300 (speculating) with Ryzen4 on the way.  When will the wait be over for a single software update for your Designer product?  Will we ever get a BIOS or fan control update, or should I just give up while I'm ahead? 

Extremely disappointed with lack of response from the greater Corsair Staff not touching on this.  I would understand if it were some cheap accessory like a keyboard or mouse but we're not talking about the toys Corsair is used to producing.  We are talking about their flagship designer product.  Says alot.  Definitely not feeling good about continuing business in the future fam.

  • Thanks 1
Link to comment
Share on other sites

Not sure what you mean by "fan control update."  The iCue link on the 1300 downloads page is up to date, and you can also update ICue through the software itself.  Perhaps I'm misunderstanding what you mean?

Link to comment
Share on other sites

Posted (edited)

@Queeg  iCue being developed universally across multiple systems primarily for control of accessory devices.  It has not provided any improvements or benefits to the i300 system since release. The fan control setup in iCue when installed on a Corsair One system is limited and ineffective with default settings allowing the system to almost always eventually overheat.  This has been a common issue on the forum and acknowledged by Corsair months ago with no update or mention. Not sure if this is effecting all systems, but multiple users including myself are experiencing this.  Additionally MSI has already released 2 BIOS updates since release and still no updates there either. Clearly not a priority. Unacceptable

Edited by zguy85
Link to comment
Share on other sites

Your experience has been different from mine.  With both my i160 and i300, iCue has always worked fine, both in Default and Custom mode.  I always update the software with each new release and it just works.  So the problem you describe is not universal.  Sorry you're having problems. 

Link to comment
Share on other sites

I should add that, on both my machines, I typically use a 40-50% Custom setting.  I've used the Default setting, too, just not as often.  No problems with it, though. 

Link to comment
Share on other sites

The dashboard settings in my i300’s iCue keep disappearing.  About 50% of the time I startup my pc the dashboard tab is empty.  Everything up to date.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...