Jump to content
Corsair Community

K60 keyboard not showing up in iCue when going through KVM switch


Recommended Posts

The keyboard functions for typing when going through a KVM switch and the default RGB/hardware lighting turns on but it doesn't show up in iCue. I plugged it in directly to my PC and it shows up in iCue. But I share my keyboard with my work laptop and need to be able to use it for that without RGB on and then be able to switch to my personal/gaming computer and have RGB through iCue when I desire. Is that just the way it is? (things will never be the same). Or is there something I can do?

Link to comment
Share on other sites

Well scratch that - I just tried plugging it into a different USB port on the switch rather than the one dedicated for the keyboard input and it shows up and fine and works for typing as well.

Link to comment
Share on other sites

  • Corsair Employees

Unforuntely when attempting to utilize our products through KVM Switch, USB Hubs/Switches, etc... they can cause issues with the iCUE software being able to detect them. As such we do not support our keyboards and mice being plugged into such devices. Glad to hear you were able to resolve the issue by switching to a different USB port though.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...