Jump to content
Corsair Community

Corsair H100i RGB PLATINUM Not Detected in ICUE Software


Recommended Posts

Hello Everyone,

I'm having issues with my Corsair H100i Cooler not being detected by the ICUE software. I'm able to change the color of my RGB RAM as well as all the cooling fans (including the fans on the H100i) but for some reason the pump head on the CPU doesn't appear on ICUE.

I've tried resetting ICUE, uninstalling and reinstalling ICUE, deleting all the associated files relating to ICUE,  and reinstalled the pump head USB, which is connected directly to a motherboard JUSB, with no luck. In device manager, it says that its listed as a USB Device that is connected but still wont be recognized in ICUE.

Here's my build down below:

Intel Core i5-9600KF 3.7 GHz 6-Core OEM/Tray Processor

Corsair H100i RGB PLATINUM SE 63 CFM Liquid CPU Cooler

MSI MPG Z390 GAMING EDGE AC ATX LGA1151 Motherboard

Corsair Vengeance RGB Pro 16 GB (2 x 8 GB) DDR4-3600 CL18 Memory

Gigabyte GeForce RTX 2080 SUPER 8 GB WINDFORCE OC Video Card

Corsair iCUE QL120 41.8 CFM 120 mm Fans 3-Pack

 

I'm not sure at this point what else I should do so if anyone has any other suggestions, I'm open to it!

Link to comment
Share on other sites

  • Corsair Employees

How are you able to control the RGB fans connected to the cooler if the cooler is not appearing in the iCUE software?

Link to comment
Share on other sites

On 5/16/2022 at 8:42 AM, Corsair Notepad said:

How are you able to control the RGB fans connected to the cooler if the cooler is not appearing in the iCUE software?

Its connected to the Lighting NODE Pro

Link to comment
Share on other sites

On 5/16/2022 at 8:42 AM, Corsair Notepad said:

How are you able to control the RGB fans connected to the cooler if the cooler is not appearing in the iCUE software?

All the fans are connected to the Lightning Node Pro through Corsairs RGB Hub. So I should be able to change the color of the cooler but for some reason its not recognized as a device in ICUE

Link to comment
Share on other sites

  • Corsair Employees

What exactly are you plugging the USB cable from the cooler into?

Link to comment
Share on other sites

  • Corsair Employees

Have you tried swapping the USB header to make sure its not an issue with the USB header you have the cooler plugged into?

Link to comment
Share on other sites

I switched the USB to the cooler header to the other JUSB on the motherboard and that didn't work. I would think that if the USB cord didnt work properly then it wouldn't register on Device manager as a device under Universal Series Bus devices.

Link to comment
Share on other sites

  • Corsair Employees

Perform the steps in the link below and make sure you download and install the latest version of iCUE 4.

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

Link to comment
Share on other sites

  • Corsair Employees

If you have a Micro-USB to Type-A cable test by plugging it into a USB port on the back of your motherboard and see if iCUE picks it up then. 

Link to comment
Share on other sites

  • Corsair Employees

Its most likely a defective unit at that point. We would recommend that you reach out to our support team by opening a ticket at http://help.corsair.com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...