Jump to content
Corsair Community

commander pro seems dead


Recommended Posts

I bought parts to build a fresh gaming machine before I put the SSD in and I powered up the system and let it run over night to bleed the air out of the water system. At this time all the fans were working and the RGB was also working. I had a TT 1200 watt psu that the fan was making a clicking noise, so I pulled the psu and 2 days later I installed the new HX1200 at which time the RGBs stopped working and the fans stopped. When I swapped out the psu I also added 2 sp140 fans for the case.

I took the commander pro out and hooked it up to the USB in my other computer and plugged in the sata and it still does not light up the power LED

I need to return it for a new one but it came with a kit Corsair Hydro X Series iCUE XH305i RGB PRO and it is not really feasible to return all of so how can I do a return for the one item and maybe the RGB fan node to be safe.

 

Link to comment
Share on other sites

  • Corsair Employees

Did you make sure to swap ALL the PSU power cables when swapping out the power supplies? Looking up your Thermaltake PSU they have similar cable connectors as ours but they are NOT the same cables or same pinout. Sounds like you damaged the components by utilizing a Thermaltake PSU Cable with our HX1200, in which case you will need to purchase a new separate Commander Pro to replace the one that was damaged.

Link to comment
Share on other sites

On 5/12/2022 at 11:17 AM, Corsair Notepad said:

Did you make sure to swap ALL the PSU power cables when swapping out the power supplies? Looking up your Thermaltake PSU they have similar cable connectors as ours but they are NOT the same cables or same pinout. Sounds like you damaged the components by utilizing a Thermaltake PSU Cable with our HX1200, in which case you will need to purchase a new separate Commander Pro to replace the one that was damaged.

how do i return this for replacement?

Link to comment
Share on other sites

  • Corsair Employees

You will need to open a support ticket by going to the support link at the bottom of the page and opening it there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...